3

So what happened is that my mobile (Galaxy S4 - GT-9500) ran out of charge.

When I plugged in the charger and tried to turn it on, it went directly to what I think is the recovery mode (Android logo with text "Downloading...Don't turn off target")

I turned it off, pulled off the battery and tried to turn it on again nothing happens.

I tried different solution but nothing happens, just the black screen Here is what I tried so far:

1- Home + on/off button + volume up

2- Home + on/off button + volume down

3- plug it in the PC for hours and then along press on the on/off button

Any other suggestions ?

  • Leaving the battery out for a little longer (e.g. 1 minute) might be worth a try. Also check that there's no "stuck button" which might causing this (unlikely, but who knows). – Izzy Jul 1 '13 at 11:11
  • 1
    @Izzy Unfortunately this did not work also. I even plugged the wall charger in for a long time and nothing happened – Abdel-Rahman Shoman Jul 1 '13 at 12:16
  • I'm reluctant to suggest the last-ressort: Can you still do a factory-reset? Apart from that (and giving the device to service), I'm out of ideas as well. – Izzy Jul 1 '13 at 12:31
  • IF you mean the (volume up, home, on/off button) no I am not. However I guess I am not getting it well, could you please tell me how to do it ? – Abdel-Rahman Shoman Jul 1 '13 at 12:42
  • Too long for a comment, but see hard-reset.com. If that works out, I will include the steps in an answer, of course. – Izzy Jul 1 '13 at 13:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.