2

I did see this question, but it was from two years ago, so I know it does not apply to my question.

Before the 10/1/2013 update, I was able to easily switch my sender email account to a different email address, but now, I can't. I have checked the settings in the app and for the email account.

Is there a setting somewhere in 4.6 that I am missing or did Google kill this feature for the mobile version?

If my question isn't clear, I apologize, and please let me know how I can improve it.

I'm using: Nexus 4, Android 4.3

After further investigation, it may be broken: gmail forum post

Thanks.

  • No repro here. In the compose window, if I tap my email address I get all of the "Send mail as" options I have for that account, as well as the email address for the other account I have on the device. (Gmail 4.6 on a Galaxy Nexus with Android 4.2.2.) – ale Oct 7 '13 at 15:13
  • That is not happening for me when I compose emails emails. I thought it may have been limited to replies, but I can't do change it. I have a Galaxy Nexus at home, so I will update the app there and try it when I get home. Thanks. – Waddler Oct 7 '13 at 15:28
  • Have you made sure you have all the accounts set up on the device and syncing Gmail? Have you tried clearing the data/cache of the Gmail app? – ale Oct 7 '13 at 15:42
  • I just cleared the cache. AND IT WORKS! :) Forgot about that until I was poking around the app settings. I was this close to rolling back the update. Thanks @AlEverett. – Waddler Oct 7 '13 at 16:07
  • 1
    Please don't put the solution in your question. Make it an answer and "accept" it so it can act as a signpost for future readers. – ale Oct 7 '13 at 16:43
2

SOLUTION: Clear the app cache. After I cleared the app cache, the "send as" was functioning as it did before the update.

Does this fall under as a duplicate of: App X Isn't working correctly. How can I fix it?

  • Not necessarily a duplicate, but it's good to know clearing the cache helped. :) – geffchang Oct 8 '13 at 0:10
  • Clearing cache and app data didn't work for me. – seanmonstar Nov 22 '13 at 0:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.