0

I got my nexus 7 2013 a few weeks ago. It worked great for some time until I decided to flash a kernel that claimed to add support for CIFS windows shares mount. After installing this kernel, when the OS booted, I did not have landscape mode working anymore - only portrait. I decided to do adb full restore to a full backup i made before this step, which seemed to have passed without any errors, but something happened to the recognition of the internal SD memory - applications are not able to use it - I am getting "no external storage" messages when I launch the gallery application and an error when trying to run the google play store - "unfortunetley, google play store has stopped". The device is still starting with only portrait mode.

i then tried to format the device and used TWRP to format everything including the internal memory. After that I reflashed the original rom of google for this device (taken from here). The problem is still the same. In TWRP recovery console - I am able to access and push files to and from /sdcard folder with no problems, and see its content with adb shell.

When android loads - cd /sdcard + ls shows that it is empty (even though it does contain files copied to it in recovery console mode) the reason for this is that with ls I can see that /sdcard points to /storage/emulated/legacy which points to /mnt/shell/emulated/0 which DOES NOT exist. /mnt/shell/emulated/ folder exists, but it is empty.

I am unable to use the device - just start the OS (and get the error messages when trying to launch applications). When the OS loads I immediately get the "unfortunetley, google play store has stopped" error without doing anything.

running google earth application when logcat active gives the following output:

E/cutils  (10727): Failed to chmod(/mnt/shell/emulated/0, 0): Read-only file system
E/dalvikvm(10727): cannot mountExternalStorage(): Read-only file system
I/ActivityManager(  492): Start proc com.google.earth for activity com.google.earth/.EarthActivity: pid=10727 uid=10024 gids={50024, 3003, 1015, 1028}
D/dalvikvm(10727): No JNI_OnLoad found in /system/lib/libearthmobile.so 0x41dc5158, skipping init

Any idea how do I solve this? Why are the folder links broken when I am using an original google rom?

  • Are you sure the kernel you flashed was intended for Android 4.3? Though mount-points shouldn't be kernel-dependent, I don't know what "shipped along the lines". With Android 4.2, some mountpoints have changed for the multi-user support – which happen to be the very same you're now having trouble with. – Izzy Nov 10 '13 at 16:22
  • yes - taken from here: developers.google.com/android/nexus/images#razorjss15r (the wifi version) – Liran Nov 10 '13 at 22:44
  • OK, so that's ruled out at least. Hopefully there are a few kernel/Nexus-7 specialists around here to help you out. Good luck! – Izzy Nov 11 '13 at 0:39
  • updated the post with some new info – Liran Nov 16 '13 at 9:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.