5

I have installed an app which needs root. Whenever the root manager gives it root permissions, it makes a toast popup that says "[app] has been given root permissions".

My problem is that it shows this popup every time the app is used or opened. This is annoying. How can I disable this toast notification so I don't see it anymore?

6

That's part of the SuperUser app's settings. Looked up on my Milestone² running Gingerbread:

  1. Open your SuperUser app on the Android device
  2. Hit the "wrench" symbol in the upper right of the screen to go to its settings
  3. Scroll to the "Notifications" section
  4. Uncheck "Notifications"

On ICS and up, the wrench symbol might be no longer. At least chainfire's SuperUser has a Holo GUI there. If that's the case for you, there should be a "Settings" tab visible instead, so use that.

Edit: Here's a screenshot I've found at AddictiveTipps:

Screenshot
Screenshot (click to enlarge)

Note the last item displayed, that's where you can trigger it in ICS and up.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.