1

was trying to install a custom ROM, but got stuck into CWM boot loop. learned that this could be solved by entering the download mode and flashing a new firmware, but my phone has been showing the "downloading..." screen for over an hour. is this normal?

  • Did you actually flash the ROM successfully? Is it entering download mode automatically when you tried to boot it up? – eldarerathis Jan 16 '14 at 22:39
  • @eldarerathis I entered the download mode by pressing VOL DOWN + HOME + POWER buttons. It asked me whether I want to install the ROM or to cancel and I chose to install it. Now it's showning Download... do not turn off target! and that's it – Kareem Jan 16 '14 at 22:41
  • So you did successfully install the ROM using Odin or Heimdall on your PC? Did you reboot after that, or did it reboot itself or anything? Did you receive any kind of success or error message in Odin/Heimdall? Typically I think the phone reboots itself after the flashing process has finished. I ask because I'm not clear on where in the process you actually are right now. If it's just sitting there then it sounds like it's not actually doing anything, either because the install failed or was never initiated on the PC end. – eldarerathis Jan 16 '14 at 22:45
  • @eldarerathis I did something related to Odin too long ago in order to root my phone, but I didn't do this before entering the download mode or even while I'm in now. and I remember that it ended with a success without showing error messages. – Kareem Jan 16 '14 at 22:46
  • @eldarerathis so, do you think it's safe to power it off now (since it's not connected to the PC and has nothing to do with Odin) and repeating what I did with Odin after connecting my device to the PC? – Kareem Jan 16 '14 at 22:52
4

I think this might simply be something of a misunderstanding regarding how "download mode" works exactly. When you reboot into download mode, your phone doesn't automatically reflash itself. It's not capable of doing that, and in general this is a rare feature (Nook tablets can do this, notably, though not with "download mode"). Instead, it's simply listening for commands from a PC, delivered via the Odin or Heimdall utilities.

The reason your phone has been sitting in download mode for over an hour is because you haven't yet told it what to install. Again, it won't do anything by itself, so If you didn't use Odin to install the ROM then it's waiting for you to do that. You'll need to get Odin (or Heimdall), find a ROM to flash, and then hook your phone up to a computer and actually perform the installation. Once that's done, it should reboot into the new ROM, but until then it will just hang out in download mode waiting for commands.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.