I'm using the stock e-mail client in Android 4.3. I have a file in my Downloads folder that I want to send in an e-mail. When I try to attach, it asks me where I want to get the file from. Most of the apps are unhelpful (Images, Video, Calendar, etc.) The only one that looks like is helpful is "My Files" which has an icon of a folder on it. Why it doesn't offer any of the File Managers I have installed, I don't know.

But when I tap on "My Files" and it brings up a file explorer, I can navigate to the Downloads directory, but when I try to select the file to attach, it pops up a new "Complete action using" modal dialog. If I try to open it with anything, it goes to that app, instead of returning me to the Email app. There is a Cancel/Done selection in the upper right, but only Cancel is allowed. What do I need to do to cause a selection (so that the Done option is allowed) without it popping up something that prevents me from completing the action? I have already looks at the menu (no help) and have tried long tapping (does nothing until I release, then brings up the same modal dialog that a short tap does).

1 Answer 1


It may be your file explorer isn't written well. You could try to use a different file explorer, such as ES File Explorer.

Or, try going about it from a different way. Instead of using your email program to look for an attachment, use your file explorer to 'share' the attachment, and choose to share it via your email app. It will add the file as an attachment and open your email app. As long as your email client is listed as a possible 'share' app, this should work.

If neither of those work, try getting a new email client. Since the email client isn't showing all of your file explorer apps when selecting to add an attachment, it may have written its own (poorly designed) app selector.

  • It's apparently the stock explorer built into Android (there isn't any App that has this icon); the two File Explorers (FX and Astro) don't show up. The "Share" equivalent worked great though, so I'll accept on that. Thanks!
    – Michael
    Mar 17, 2014 at 19:33

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .