2

I have an HTC One running Android Revolution HD (ARHD), with Android 4.4.2, and I've been getting this error that says "Bluetooth share has stopped working".

The problem is that I have no clue what's causing this error to appear. I think it started appearing after I clicked the "share" button in an app - but even after fully rebooting my device, I STILL keep getting this error.

Does anyone know what could cause this error? And more importantly - how do I debug what app is causing this error? I just don't even know where to start investigating.

  • Is "Android Revolution HD" a custom ROM? That's probably the issue, could be the ROM, could be the Kernel. Have you tried any other ROMs to see if this resolves it? – RossC Apr 8 '14 at 10:23
  • Try to clear data in Settings -> Applications -> All -> Bluetooth Share -> Clear data. – Min Naing Oo Apr 8 '14 at 11:29
  • Thanks for the comments. @RossC yes, it's a custom ROM but no one else seems to be seeing this issue - I feel like it's probably due to an app I have installed, but I can't figure out which. Min I tried that, but I'm still seeing the error. – FrankieA Apr 8 '14 at 22:45
  • Hmm, you could try Greenify, which hibernates applications. Throw a load of them in there and try to replicate the issue. Then you can narrow down the culprit! It's probably easier than uninstalling a load of your apps (but you could Titanium backup them too)! Maybe install a 'logcat' application and see what the specific error message is and then you'll hopefully know exactly what is wrong! You could post it here for clarification if it's not immediately apparent. – RossC Apr 9 '14 at 13:23
  • @RossC Thanks for the ideas! I decided to try disabling apps that potentially use bluetooth one by one to see which one fixed the issue and I found the culprit (I think)! Turns out it was Automatic app (car app) that seemed to cause it. I've filed a bug and kept it disabled for now. :) Thanks guys! – FrankieA Apr 9 '14 at 20:39
0

The only way I could fix this on my HTC One V was to perform a factory reset.

  • Please don't use ALL CAPS. – Flow Jul 13 '14 at 16:29
0

Go to settings/apps/ show system apps and find any bluetooth related app and force close and wipe data of the apps, reboot and see if that clears it up. Else as mentioned factory reset.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.