One of my co-workers has a HTC Desire CDMA phone and is having a problem with flashing CM7 with Google Apps. It flashes CM7 just fine, and it even says that it installs the Google Apps zip (the GB version) just fine, but in reality, it isn't flashing any of the Google applications. I can try manually flashing the gapps zip file and it will still say it installs successfully, but there are still no Google Apps on the phone.

What else can I try to get Google Apps installed on his phone?

  • 1
    Did you reboot the phone before any of these flashes?
    – newuser
    Commented Apr 27, 2011 at 14:52
  • @JonnyP the first flash was via Rom Manager. When I tried to manually flash it, I booted it into recovery and flashed from the gapps zip file on the sdcard
    – Bryan Denny
    Commented Apr 27, 2011 at 14:54
  • 1
    @JonnyP so I guess my question back is: does booting from phone into recovery not count as a reboot? Do I need to turn it completely off and then boot into recovery?
    – Bryan Denny
    Commented Apr 27, 2011 at 14:56
  • What version of CWM Recovery is the phone running? Commented Apr 27, 2011 at 15:01
  • In my (admittedly very limited) experience doing a normal reboot and then rebooting into recovery seem to have different effects on the phone. When I originally flashed CM6.2.1 on my Droid I installed it via ROM Manager and then had similar issues with GApps, so I rebooted the phone, let it come back up naturally, and then re-flashed the GApps and I ended up getting them on successfully that time. Obviously though with the phones being different and no guarantee that my issue was the same as yours your results may vary.
    – newuser
    Commented Apr 27, 2011 at 15:01

1 Answer 1


Some people are reporting success by simply wiping data and cache first, then flashing the ROM, wiping cache again, then flashing the Gapps package. Thread on the CM forums here (from CM 6.1.1, don't know if it's a related or similar problem, though).

The flash might not work on a 2.x release of CWM. You can get here, but I don't know how stable it is right now. The filesystem changed to ext4 in Gingerbread and I know the 2.x releases aren't really supported on other devices. They also changed from one update scripting language to another, which I think is related. It creates generally weird behavior from what I've read...

Edit: Also looks like you can get CWM from the CyanogenMod Forums now.

Some relevant discussion can be found on XDA here (from the Desire HD section).

Edit: Since Bryan noted that this solved it for him in the comments: It's also possible to simply push the apps manually onto the system partition. The safest way is probably to boot into recovery, then just mount /system as rw and adb push the .apk files to /system/app. You probably could do it from a regular boot (not in recovery) but it might cause some weird behavior (and I have not personally tried this).

  • I'll grab his phone again and try the wipe --> flash CM7 --> wipe cache --> flash Gapps. If that doesn't work I'll see if I can get 3.x recovery on the phone
    – Bryan Denny
    Commented Apr 27, 2011 at 15:36
  • @eldarerathis Had no luck doing either method. We flashed CWM, then wiped data/cache, flashed CM7, wiped cache again, and flashed Gapps. Still no Google apps showing up
    – Bryan Denny
    Commented Apr 27, 2011 at 19:12
  • @Bryan: That's truly bizarre...out of curiosity, can you manually mount the /system partition in rw mode from recovery? That's usually the sticking point for this kind of thing, but the issue usually seems to be resolved by going from CWM 2.x -> 3.x. Incidentally, I suppose you could try manually pushing the .apks to /system/app in recovery mode if the mount works. Commented Apr 27, 2011 at 19:32
  • @eldareathis I can manually mount /system. I've flashed CW 3.x and still no luck. System/apps/ is not showing the apps after flashing the gapps zip (although it says it was successful). I think I'll try manually pushing the apks.
    – Bryan Denny
    Commented May 3, 2011 at 15:02
  • adb pushing the contents of the gapps.zip to the system partition worked :)
    – Bryan Denny
    Commented May 3, 2011 at 15:17

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .