0

Dirty updated from OmniROM to latest CM11, fixed permissions, and got crashes. Firstly crashed com.android.phone, I have removed some files and managed to fix it. After it I have tested a little and experienced other crashes: com.android.themes.provider (when trying to enter to any submenu of themes menu) and com.android.settings (when trying to enter cellular network settings) . What files should I remove to fix it? I tried to clear .themes.provider's folder and .settings' folder, it doesn't help.

0

A dirty upgrade is never 100% error free. You have to either fix permissions (worked out for me) or wipe data and reinstall everything. Also check the owner and group of all the files and folders, they tend to be different even on the same Android version.

  • I have already done fixing permissions: both via recovery and via nandroid manager (fixes permissions for apps, recovery doesnt do it) – KOLANICH Dec 25 '14 at 11:10
  • I mean manually eg with rootexplorer. Check read, write and execute permissions as well as owner and group. Fixing permissions with recovery didn't work for me, only the manual way. – GiantTree Dec 25 '14 at 11:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.