0

I have Samsung S3 GT-I9300

It was working fine but suddenly, I turned it on and it is stuck on the Samsung LOGO forever. It doesn't go to recovery mode when pressing HOME+VOL UP+POWER. But I can still go to Download mode. However Odin fails to install CWM and TWRP or official recovery

I tried to install Bootloader_XXELLA_Odin.tar via odin but it failed and now I start getting this message : "firmware upgrade encountered an issue. please select recovery mode in kies and try again"

I can still go to download mode, what I can try now? Please if you have an answer be specific, or if you suggest to flash a boot-loader I would appreciate providing a single link (not a page with bunch of links).

Update

Now the problem is worse, I tried again to install CWM via odin after I disabled antivirus (thinking it maybe the cause). But the install failed again, and the phone is completely dead! It shows NO sign of life. No light, nothing.

  • Drivers ok? Does Odin detect correctly the device? – Joaquin Iurchuk Jan 13 '15 at 3:09
  • yes it does detect it, but it always fail to install flash rom, or recovery. – member0123 Jan 13 '15 at 11:06
  • Try another version of Odin (newer is best), or Heimdall (please note Heimdall doesn't accept .tar or .tar.md5 files, but raw .img/.bin/zImage files) which is a community made alternative. – georgeunix Jan 13 '15 at 15:54
  • I used the latest Odin version of Odin3.10.0 and Odin_3.7, but the same problem. I don't know "Heimdall", can you please contribute more, what I should try to flash now, bootloader or recovery or rom? and where to get the correct flash for I9300GSMH unlocked international – member0123 Jan 13 '15 at 17:25
1

What were you actually doing with your Phone? Did you try to install custom ROM/Recovery/Kernel/Mod and so on?

I too have S3 GT-i9300 which is working fine after replacing my motherboard because I came across Sudden Death Syndrome (SDS) in S3.

  • If you are able to go to download mode then download the latest Stock version of S3 which is 4.3 JellyBean and flash it via latest odin.

  • Make sure USB Debugging is ON in your phone and your phone driver must be installed correctly.

  • You may use this link to download driver for Samsung Mobile.

  • Make sure before installing this software all the other previous/old driver are uninstalled.

  • I would recommend that you should try to ADB to see your phone has proper drivers installed. Just Google ADB and download it. (Put all the files in one folder named adb.)

  • Press +R to open Run. In it type cmd. Now Command Prompt should have started. (I assume that you put the folder adb in root of C: drive) Type the following commands.

    1. cd <space> / - this will take you to root of C: drive
    2. cd adb - this will take you in adb folder.
    3. adb devices - this command will show all the devices currently attached to your system.

      If you can't find any device then it means drivers are not properly installed.

Try it, hope this may help you.

0

You have to go to download mode by pressing power button, home button and volume down key at the same time.

When screen shows download mode, press up volume key and enter in this mode. Now start odin and press PDA key and select TWRP.zip (which should be downloaded already from the net) and now start to flash it.

After pass message your phone will be restored to boot procedure, at this stage you can download any rom to your S3 i9300.

  • He specifically said in his question that he already did all this but it failed. – Vic Sep 23 '15 at 16:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.