1

Has anyone experienced it before? The speech recognition (Google Now and speech input) is not working in Redmi Note 4G at all. I've tried cleaning cache, re-training, re-authentication, etc. but every time it says- "Didn't catch it. Please try again." Can anyone please tell me what's wrong? Thanks for your help!

P.S: I'm having excellent WiFi connection with mic turned on. I've also checked all permission settings.

1
  • Of course I checked my microphone. Voice recorder is working fine. It just seems like the voice recognition service is not able to process the input. And I can assure you, it's not the network connectivity problem. In the same network and same app settings, Google Now is working like charm in my Xperia Z. Jan 27, 2015 at 5:24

4 Answers 4

0

Apparently, this is a known hardware issue on the RedMi Note 4G. The top microphone doesn't work, only the bottom one. Talk directly into the bottom of the phone and Google Now should work just fine. BTW, the 3G version of the RedMi Note (w/ MTK chip) works just fine. Chinese QA sucks.

0

I had the same issue and fixed it with these changes:

  1. Open Root Explorer and go to BUILD.PROP

  2. Search for: persist.audio.fluence.voicerec=true

  3. Change it to this: persist.audio.fluence.voicerec=false

  4. Reboot your Device

Google Now and Maps both work fine and recognize "Ok, Google"

1
  • Can you please tell me, from where did you find the rooting toolkit for MIUI? Apr 21, 2015 at 2:23
0

Change the language in Google settings to "English US' and then retrain the voice.... I tried this in Redmi 2 and it worked for me...

-1

Well, you have to enable it in manage permission. Go to settings - general settings - app - google search - manage permission (scrolldown to last) - enable trust this application and auto start. Thats it. Please ensure permission in given to this app for data/wifi as you choose.

1
  • 3
    Please read the question again.It clearly states that permissions have been checked already.
    – GiantTree
    Feb 21, 2015 at 13:10

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .