0

I have been repeatedly trying to install an apk on my moto g lte (1st gen). Nothing will install. Apks worked initially, but it stopped working at one point

su pm install [apk] Returns invalid URI. The name is all standard chars.

su pm install -r [apk] Returns container error.

SOLVED I had managed to corrupt my SD card which meant the apk files could not be installed upon my phone. Taking out the SD fixed it.

  • 1. Is this a problem with an specific apk, or are you having trouble with installing any apk? 2) What error do you see on screen when you try to install the apk using standard procedure (tap and install)? 3) Did you consider logcat to capture the logs during the occurrence of the error? 4) Could you detail more about: Apks worked initially, but it stopped working at one point? – Firelord Jun 13 '15 at 18:41
  • Thank you for suggesting logcat. I am an idiot sometimes – user2979846 Jun 15 '15 at 21:14
-1

Corrupted SD card meant I could not install anything.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.