1

I tried to install F-Droid (0.91) as system app on Cyanogenmod 12. The installation succeed but after that the F-Droid icon disappears.

Of course i tried to restart more times, i tried also to reinstall F-Droid as standard app from an apk but it crasches when i try to start it... probably for a conflict.

Someone knows if i can try something, i.e. where i can try to find the executable?

  • 1
    Worth a try: Remove the .apk completely from your device (use e.g. TiBu to delete it), download the latest .apk from F-Droid, copy it to /system/app (or where it belongs to on Lollipop – I'm not sure if it must be in the "priv" folder instead; check where it's currently), then reboot. Let me know whether this worked out. – Izzy Jul 22 '15 at 13:19
  • 1
    @Izzy I tested your solution in my CM12 exactly, it works, and the .apk should be in /system/app since I see no reason for /system/priv-app. What's bugging me is TiBu just hung up (doing processing for eternity) when I tried to convert FDroid into a system app. May be TiBu isn't updated, I need to check. // And I think you should get your hands on Lollipop soon, since you end up relying on an under for your tries. :) – Firelord Jul 22 '15 at 17:19
  • And I forgot to mention that the latest F-Droid is v0.92 and 0.91. – Firelord Jul 22 '15 at 17:20
  • @Firelord Thanks for your confirmation! I just returned home, and promptly converted my comment to a full-fledged answer. And yes, the version number was the first thing I've noticed – just hving updated the app myself recently :) – Izzy Jul 22 '15 at 17:41
3

You can solve that as follows:

  1. Completely delete the old F-Droid app (e.g. uninstall using Titanium Backup)
  2. Get the latest .apk from F-Droid and put it on your device
    (either download directly with your Android web browser, or use adb push)
  3. Login to your device either via a app or using adb shell
  4. Obtain root privileges by executing the command su
  5. Make sure to have the /system partition mounted read-write

    mount -o remount,rw /system
    
  6. Now get the downloaded FDroid.apk to /system/app. Change to the directory you've downloaded/pushed it to and run:

    cp FDroid.apk /system/app
    
  7. Secure your /system partition again

    mount -o remount,ro /system
    
  8. Reboot

Now F-Droid should be available to you again. Enjoy the great pool of open source Android apps!

  • 2
    +1, but I ignored steps 3-7 and used a file explorer like ES Explorer to do the copy-paste. :) But yeah, that ro security is important. – Firelord Jul 22 '15 at 17:45
  • 1
    @Firelord Yes, I had that in mind – but preferred a more "generic" solution :) Your command adds the other option, so I'll give it a +1 as well :D – Izzy Jul 22 '15 at 19:46
  • It hasn't worked for me :( : adb shell shell@totoro:/ $ su root@totoro:/ # mount -o remount,rw /system root@totoro:/ # cd /mnt/sdcard/download/ root@totoro:/mnt/sdcard/download # cp FDroid.apk /system/app cp: can't create '/system/app/FDroid.apk': Read-only file system – pak0 Jul 23 '15 at 11:53
  • .... even after the mount command, when i check with cat /proc/mounts the path /system remains in read-only: /dev/block/mtdblock8 /system yaffs2 ro,seclabel,relatime 0 0 – pak0 Jul 23 '15 at 12:00
  • I'm pretty confused: if you cannot mount /system read-write, there's not much you can do – so you should first figure why that part fails (hint: check the logs, e.g. using logcat – see our logging tag-wiki for details if needed). – Izzy Jul 23 '15 at 13:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.