4

My device: Karbonn A52+

Android 4.2.2

Mediatek MT6572 CPU

Root Access: Yes

Bootloader: Unlocked

I'm trying to flash the official system.img of my device's stock ROM which I have with me, over fastboot.

However, when I run the command: I get this...

C:\Users\Tanmay>fastboot erase system
******** Did you mean to fastboot format this partition?
erasing 'system'...

And this goes on forever. Does not go further this. If I directly run this command without going through the above process:

E:\OS\Mobile\adb>fastboot flash system system.img
erasing 'system'...

Same thing happens, it gets stuck at erasing 'system'...

Other fastboot commands work fine:

C:\Users\Tanmay>fastboot devices
mt6572v1_phone  fastboot

Also, commands like fastboot reboot, fastboot getvar all, work fine.

I'm only facing problem with erasing system. I am unable to figure out why it happens with this command. Is it possible I'm being impatient? I abort it if it doesn't respond after 3-4 minutes.

4
  • Try flashing boot or cache and see how long does it take. I somewhere heard that some MTK devices can't be flashed using traditional fastboot method.
    – Firelord
    Oct 18, 2015 at 18:40
  • 1
    @Firelord that maybe possible. Coz when I try to flash a recovery, I get this: E:\OS\Mobile\adb>fastboot flash recovery recovery.img sending 'recovery' (5090 KB)... OKAY [ 0.198s] writing 'recovery'... FAILED (remote: partition 'recovery' not support flash) finished. total time: 0.242s
    – Tanmay Vij
    Oct 19, 2015 at 7:26
  • And yeah, the same thing happens with cache as well. It gets stuck at erasing 'cache'... And I didn't try with boot.img as it maybe unsafe for my device if something goes wrong..
    – Tanmay Vij
    Oct 19, 2015 at 7:34
  • I'm facing the same issue, changing cable did not help
    – ransh
    Dec 22, 2016 at 11:15

2 Answers 2

1

As amazing as it seems, changing the cable and USB port on the PC worked for me.

Reference: http://androidforums.com/threads/nexus-7-2012-ruined-bootloader.794839/

1
  • I'm having the same issue, changing cable did not help
    – ransh
    Dec 22, 2016 at 11:14
1

Its also note to myself. Use the " -u " switch with the fastboot.

fastboot -u flash system system.img

It appears that its the USB cables fault or cheap USB cables or bad software in the mobile!!!, that does not send "completed" response for the operation you requested.

So adding the "-u" will not erase the partition, it will only overwrite the partition, which also erase. And of course its "safe".

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .