1

I have a Leagoo Lead 3 running Android 4.4 KitKat. After factory resetting it, I'm no able to add my Google account.

The error I receive is

Couldn't sign in
There was a problem communicating with Google servers. Try again later.

Googling it, I find that the hosts file in /system/etc needed to be modified to comment out xxx.xxx.xxx.xxx android.clients.Google.com, but I don't have this line.

Also, I checked HTTP traffic with Fiddler and I just have this :

"200 HTTP Tunnel to 173.194.40.142:443" with body 0

It seems to be a good Google IP.

I don't know what to check now. Any help will be appreciated.

2 Answers 2

0

According to this post on Google Forums:

  1. Check if two-step verification been enabled on the account (https://support.google.com/accounts/answer/185833?hl=en&ref_topic=2784804)?
  2. Try to open a browser on the device, go to https://mail.google.com/ and sign into your account.
  3. Also try the Unlock Captcha function (http://mail.google.com/support/bin/answer.py?answer=78754): https://www.google.com/accounts/DisplayUnlockCaptcha You can try disabling IMAP (from the web-interface) and re-enabled it. Or deleting the account from the device and setting it up again.

NOTE: When two-step verification is enabled for an account, you need to create an application specific password (to be used in place of your regular password) for any client/application/device that doesn't know how to ask for the 2-step code (like your phone).

Check https://support.google.com/mail/bin/answer.py?hl=en&answer=1173270

From: https://productforums.google.com/forum/#!topic/gmail/zGCCBpsvusw

Other possible solutions:

The first one works if you can't estabilish connection to Google servers, the second one needs rooting the phone (Remember: you do it only on your own risk)

Hope it help

1
  • Thank you for your help, but I finally flashed a rom to retrieve connection. The first solution shouldn't have worked because I had no connection at all, like I saw it with fiddler and using anything as email and password did the same. The second solution is what I tried like I said.
    – Entretoize
    Jan 2, 2016 at 7:30
0

From QYOBZ's post on XDA Forums - [SOLUTION:] Can't Establish a reliable connection to the server/Playstore No Connect

  1. ROOT your device (of course)

  2. Editing the file
    You will need a proper editor
    Download and Install Total Commander and open it
    OR DOWNLOAD BELOW

  3. Browse with Total Commander to root/etc
    (hint: on the right side of the screen there's a shortcut to system folder.. look for etc/ and you will find it)
    Tap mount R/W
    Long tap on "hosts" > edit file > Totalcmd-Editor

    Open etc/hosts and edit the file. Just put # before 74.125.93.113 android.clients.google.com.

  4. SAVED

    Edited file should look like this:

    127.0.0.1 localhost
    #74.125.93.113 android.clients.google.com
    

    remember: based on my own observation it should be look like this:

    127.0.0.1(just one space)localhost
    #74.125.93.113(just one space)android.clients.google.com
    
  5. Turn OFF your device.

  6. (Not Necessary, Go to Next Step. But if the problem persist do Factory Reset..) Got it on Recovery Mode, Factory Data Reset, wipe data.

  7. Reboot your device.

  8. Once the phone reboots, input your google account information when the phone asks for it.

  9. Sync to your account and contacts

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .