6

I have a Galaxy S6 through Sprint and just upgraded to Android 6.0. Since the OS upgrade, my text messages have been seemingly randomly changing color. The text is always the same color, but the background of the bubble will change (yellow background on my messages, white background on incoming messages).

I thought initially the color change was caused by message status - sending, sent, received, etc. This does not seem to be the case, as once one turns yellow or white, it stays yellow or white.

I also thought that the colors corresponded to messages that I or my texting partner had not responded to (I sent 2 in row to her 1 incoming or vice versa). This also does not seem to be the case, as I have been able to send multiple in a row without the color changing.

Do you know what the different background colors signify and how to turn them off?

screenshot

"Light-blue text bubble" anomaly compared to normal text bubble (dark green and blue)

  • 1
    @AndrewT. I've added a screenshot. This is not 1 message that was broken into 2 because of it's length. There are also examples of multiple replies from one party with none of them changing color. The bubbles are yellow on my side when it happens – rogerdeuce Mar 22 '16 at 17:40
  • Enhanced messaging setting, and if the message is SMS or MMS will affect how messages are sent and received. Do you have enhanced messaging on or off? Was the blue message MMS, SMS, part of a group message? – user157509 Mar 23 '16 at 2:34
  • enhanced messaging is turned off, and has been – rogerdeuce Mar 23 '16 at 13:00
  • 1
    @benjaminS There is a stock theme on the phone that has black background. I've been using the same theme for 6 + months. Text bubbles started changing colors with marshmallow 6. No rooting or roming or anything like that going on, on this phone. – rogerdeuce Mar 30 '16 at 13:08
  • 1
    @rogerdeuce thanks for the info. I don't have a solution sadly - my best guess is that this might be the new behaviour - but that is just an assumption. I'd contact Samsung and ask if they consider this a feature and if it was intended. Contact Samsung. You can link them to this question so things will be clear :) – benjamin Mar 30 '16 at 13:26
4
+25

After a lot of research I haven't (and from the comments, it looks like neither have other users) been able to find any resources on the internet regarding this curious phenomenon.

I am, therefore, forced to accept this as some sort of Easter egg from the Samsung developers' side (although, in my opinion, Easter eggs should at least look nice.).

This also means that you don't really get an option to 'opt-out'. If it really bothers you, you can Contact Samsung (although their 'Live Chat' feature seems badly designed since I couldn't get a representative to talk to me even after 30 minutes) or use another messaging app.

  • 1
    comment by an anonymous user: if you check your theme it most likely has an update that is needed. After I updated the os I had the same problem resolved by updating the theme in the theme selection (it was noted on red that update was available) – Izzy Apr 16 '16 at 12:53

protected by Community Mar 23 '16 at 17:56

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.