I love using the Waze navigation app. However, when I am driving, I can never get voice commands to work. I've tried and tried. It always complains it didn't catch that, and sometimes without even waiting to try and capture my voice. I don't understand why.

In Marshmallow, I've disabled its ability to record audio completely because it screws up Google voice's ability to capture any commands at all, and for a pointless feature that doesn't work right.

Is there something I have set up wrong? Is there somewhere I can report a bug (with the hope of getting a response)?


1 Answer 1


I used Waze on Xiaomi Mi 4s and had the same problem. When I put three fingers on the screen, the microphone appeared but never had time to pronounce any words. It said, "I didn't hear you" (or something like that). It does that two or three times and the microphone disappeared.

Here is the solution for people who use Android phones (it worked for me). I don't know for others. The problems came from Google settings.

  1. Open Google settings
  2. Select Settings for Google apps
  3. Select Search, Assistant & Voice
  4. Select Voice
  5. Select Spoken results
  6. Select Hands-free searches only

Then I can start Waze and the voice command should work (of course you have to activate it in Waze)

In fact, we deactivated the voice answer from Google voice. It means that you still can ask questions in "OK Google", but the answer will be in text and not by voice. (It was this that made a problem with the voice command in Waze). To reactivate the voice answer in Google Now (OK Google), you have to reactivate it in the Google settings.

P.S. the voice command in Waze is a bit slow, so, wait a bit after your voice command.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .