3

One of my long-standing issues with allwinner Q8 is how its root, which was there when I brought it, can't seem to be used. No root manager came with it, so I installed SuperSU(Like a normal) to find that nothing can make requests at root. I can't even check the binary since I get a 'access denied' every time. Does anyone know how I can root functioning?

Again, Its a 'rooted' Allwinner Q8 On android 4.4.4 With stock recovery (but I'm 45% sure it has a custom ROM.

-EDIT-

An idea from Steve made me check terminal, and I ran su to get the line:

su: uid 10078 is not allowed to su

Errr... What? I assume the user is UID 10078(would make sense) or the su binary has been locking everything. Its only a one-user (in sense of Physical operator of device) system. Help!

  • Well if /system is Read-Only, chances are the SU binary didn't get installed, which is why Root would not work. You need to flash SuperSU via a custom recovery like TWRP, did you just install the app from Google Play or another site? – DukeSilversJazz Nov 10 '16 at 21:42
  • @RMarkwald I've used apps like CPU-Z to confirm that some form root exists, and SuperSU detects the binary. Neither of those were the case, I wouldn't need to ask ;) – Dan Brown Nov 10 '16 at 21:47
  • Also, A manual check of /system/system/xbin (ecking the wrong place whoops confirms the presence of the binary. – Dan Brown Nov 10 '16 at 21:48
  • Tried any root checker app? What did it tell? – Gokul NC Nov 11 '16 at 13:07
  • @GokulNC I used CPU-Z (reliable) and it says i have root – Dan Brown Nov 11 '16 at 13:17
1

If your phone does have a custom ROM have you looked in settings under the hidden Developer options menu for a switch that disables root access? Some custom ROMs will have this hidden in there. Everything can be in place to grant root, but apps won't get root if the switch is set to "Disabled" they may not appear to even request root from the SupperSU app.

  • No option there, though I know what you mean - I've seen it in CM. – Dan Brown Nov 11 '16 at 9:37
  • 1
    Sounds like you've checked just about everything I know to check. Just one last thought. Have you tried simply asking for root yourself via $ su from ADB or from a terminal app installed on the phone? If there is an app installed that is blocking root then you will probably see some sort of "permission denied" but if the phone is not rooted you might just see a new line without any error. In which case it might just be easiest to re-root the phone yourself. if you do see "permission denied" then you might just be looking for some controlling app buried on the phone somewhere. – Steve Nov 11 '16 at 18:13
  • Never thought of that! So I did it, and got the error 'UID 10078 not allowed to su.' WHAT THE HELL? – Dan Brown Nov 11 '16 at 21:26
  • @DanBrown On another terminal, take a logcat of the moment in which you issue su. If the ROM is a custom one, the culprit might be appops, so search for any occurrences of this term in the log you'll take. – Death Mask Salesman Nov 11 '16 at 21:42
  • 1
    @DeathMaskSalesman Not much more info. Shows the terminal loaded its standard shared libraries, and I can't find nothing on the issue. – Dan Brown Nov 11 '16 at 22:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.