2

It started when the regular OTA update failed to install and left me with a "no command" screen.
I downloaded a stock ROM from the official developers.google site.
I tried the flash-all script to install the ROM. It gave me the following:

archive does not contain 'boot.sig'
archive does not contain 'recovery.sig'
failed to allocate -1492308812 bytes
error: update package missing system.img

After pasting all the files from the image.zip to the parent folder with the flash-all script in it (that way the system.img is in the same dir as the flash-all script), I received the same error.

After some googling I found some instructions to flash the files manually using fastboot.
All went well and I came to the second last instruction to flash the system.
Then this happend:

>> fastboot flash system system.img
target reported max download size of 536870912 bytes
erasing 'system'...
OKAY [  0.090s]
sending sparse 'system' (520374 KB)...
OKAY [ 20.706s]
writing 'system'...
OKAY [  9.350s]
sending sparse 'system' (515510 KB)...
OKAY [ 22.374s]
writing 'system'...
OKAY [  9.586s]
sending sparse 'system' (479538 KB)...
OKAY [ 20.531s]
writing 'system'...
OKAY [  8.527s]
sending sparse 'system' (514677 KB)...
OKAY [ 21.401s]
writing 'system'...
OKAY [ 11.339s]
sending sparse 'system' (524289 KB)...
FAILED (remote: data too large)
finished. total time: 124.427s

As you can see, fastboot is already sending the data in smaller portions. What do I have to do to fix this? I searched google but couldn't find any usable fix..


The phone is an rooted Nexus 5x.

6

Turns out that some old adb tooling was in my PATH variable, so I was using an old version of fastboot..
It all worked well when I used the right version!

Will accept this as an answer in 2 days.

  • 1
    What version of fastboot are you using? I'm on ubuntu and have installed the latest in repository, but are still getting the same error. -- Lyon – Lyon Dec 9 '16 at 11:13
  • I'm using fastboot version 302830efc153-android! Have you checked your PATH variable? – Michel Dec 13 '16 at 21:03
  • I had the same issue and changing fastboot solved it. Thank you. – Jake Dec 23 '16 at 8:54
  • Great stuff - using the latest platform tools from the android website worked perfectly. Would have been impossible to troubleshoot without this. Thanks for reporting back. – Brett Larson Aug 28 '17 at 3:29
2

For those who still have the problem, you can simply use the -S option of fastboot.

In my case, it worked great with: fastboot -S 300M flash system system.img

protected by Community Jun 18 '17 at 22:51

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.