0
Phone: Xiaomi Redmi 4 prime
Rom (custom): lineage-13.0
Xposed: xposed-v87-sdk23-arm64
Root: SuperSU.Pro.2.82

Right now everything works just fine and those apps that need root privileges to work properly, asking for root permission and after granting, they work fine;

There's just one app call Performance Profile (an xposed module) that after running asserts that: "root access failed or busybox was not found"

I do have successfully installed BusyBox 6.7.3.0

What is the problem with this app?

Update 1: I uninstalled BusyBox 6.7.3.0 and installed BusyBox 1.26.2 and using BusyBox Checker Pro 2.0 got the following results showing that everything is ok.

enter image description here

  • Have you checked if the app has all the neccessary permissions in settings? – Notiflux Jun 5 '17 at 10:43
  • The app was ok with current BusyBox on the rooted stock room. And the only permission that app needs is "storage" which is granted to it already. – wiki Jun 5 '17 at 10:48
  • Maybe the module itself doesn't support CyanogenMod 13+? – iBug Jun 5 '17 at 14:01
  • 1
    @beeshyams I think the problem is what you've said. – wiki Jun 5 '17 at 14:21
0

A wild guess: You did not correctly install busybox.

BusyBox is not a simple application, it's a executable binary that should supposedly be located in /system/xbin. A correct installation of BusyBox includes copying the binary and creating symbolic links.

Judging by the version number you gave, you might probably installed something like "BusyBox installer" from Google Play or so. The (currently) newest BusyBox binary version is 1.26.1, so you may want to check again if BusyBox is installed correctly, not an app from GP.

  • Based on what you've suggested, I've done some changes that is reflected in the post. – wiki Jun 5 '17 at 13:52
0

flash rooting using SuperSU-v2.65 solved the problem.

  • Glad it got solved – beeshyams Jun 5 '17 at 15:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.