0

I have a galaxy note 4 that isn't rooted but has TWRP 2.8.5 installed. I wanted to factory data reset the device, however, I was getting the error that it was unable to mount /data. I read on XDA that I had to format data. I clicked on format data and typed in yes.

I got the message "Formatting Data using make_ext4fs function. You may need to reboot recovery to be able to use /data again. Updating partition details ... done". I see the status as "Data Format Complete Successful".

I rebooted the device, and I know the OS loaded, but I was greeted with the error "Encryption failed, cannot decrypt your device storage. You need to reset your device to factory default settings". And a reset device button. I click on the reset device button, it boots me to recovery and runs a script and again reboots to the previous error.

I tried to factory data reset it now, although it showed as successful, I was directed to the same error. Can you please advise what should be done?

Thank you

  • You may want to flash a "Forced Encryption Disabler" package, which also disables DM-Verity (if present). – iBug Jul 29 '17 at 2:11
  • I get an error when trying to flash this - imgur.com/CNoX871 "error flashing zip" – Abhishek Sha Jul 31 '17 at 2:35
  • I see people on XDA Developers succeeded after flashing SuperSU. You can acquire SuperSU here. – iBug Aug 3 '17 at 15:19
  • I don't think flashing SuperSU will help as I cannot access the GUI after booting. It immediately prompts me with the error as before. – Abhishek Sha Aug 3 '17 at 15:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.