I am using a stock Nexus S that has been upgraded to ICS 4.0.3. I have noticed that Gmail syncs far less frequently since the upgrade - at the moment it appears to be syncing approximately every 8 hours.

I cannot seem to find the menu screen that allows me to configure the frequency of the the sync.

Settings > Accounts & Sync gives me access to switch on or off syncing and would seem to be the logical place for this functionality to live, but I cannot see anything that lets me control frequency.

Similarly there appears to be no settings around this within the Gmail app itself.

Am I being blind or is this functionality no longer available?


If you use the Gmail app the mail is pushed instead of synced and therefore you cannot find the sync frequency setup.

However, if you set up your Gmail account in the Android Email app, where you can have your non Gmail accounts (POP3/IMAP/Exchange), the mail is synced and you can set the frequency in the Account settings, inside the Email app.

|improve this answer|||||
  • For what it's worth -- I have an IMAP account set up, and its settings are accessible from the Settings/Accounts page, as well as from inside the Email app. – offby1 Jan 18 '12 at 21:32
  • So if the Gmail app works on a push from Google, there's no mechanism for controlling the frequency? Push implies (in my mind - possibly not googles!) that as a mail comes it, it would be pushed to the app. This how it appeared to operate prior to the ICS upgrade. – Dav3 Jan 18 '12 at 22:30
  • Yes, that is right. When the email sync is set to push, the mails should appear in your phone at the time you get them. Therefore, no sync frequency is needed. – ajgarn Jan 19 '12 at 6:02

You can only set how much E-mails are synced in the GMail settings.
Goto Gmail > labels > organize labels > click on the label you edit want.

Now you have tree options, 4day, all or nothing. If you choose 4 days, GMail downloads the E-Mails of the last 4 days, if you choose all, all Mails were downloaded and nothing say what its doing.

|improve this answer|||||
  • I will try a different setting and see if it changes the behaviour of the app. My 3 options were None, 30days or All. 30Days was selected and I've moved it to All, Many thanks. – Dav3 Jan 18 '12 at 22:33
  • Youre welcom. If I helped you, vote up. :) – Leandros Jan 18 '12 at 23:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.