0

My most reliable device until now, this morning suddenly remained black: the screen didn't turn on. Long-pressing the power button didn't yield any reaction – nor did removing the battery (and SIM plus µSD card) for half an hour. Battery is at least half full, and the reaction is the same with a power cable connected. As at the other end of that cable currently is a Windows machine (not mine, so I cannot install anything on it), surprisingly that one was instantly searching for drivers – and the device identified is named QHSUSB_BULK. So something must be still working there.

Any idea what's going wrong there and how to fix it? As I wrote, that Windows machine isn't mine – so if a computer must be involved, it should work on Linux.

What I tried without success:

  • long pressing power button to provoke a restart/boot
  • at the same time, holding either vol-up or vol-down to see if it at least boots into fastboot/recovery. Nada.
  • pluggin into USB (just in case the battery suddenly discharged). Not even the LED lit up (which it normally does, indicating the device is charging)
  • removed battery, microSD and SIM for about half an hour, put it back – no change.
  • searched the web for possible solutions; only found that QHSUSB_BULK mentioned with solutions on some Nexus and/or LG devices, involving the install of very (LG) specific Windows software (not possible for me, and won't help anyway as in my case it's no Nexus or other LG device). Reading between those lines, it seems to indicate trouble with the bootloader. Confirmed by other findings of the problem (without solutions) involving devices from Huawei and a Moto G with a solution again not applicable to my case (similar thing for a Oneplus). Found one mention of the Wileyfox Swift on a Russian forum (4PDA) mentioning some special software (QFIL) again but no details, quote: "it is possible to try to flash through QFIL. In a personalized reply."

Device is a Wileyfox Swift (1st gen), still running its original CyanogenOS 12.1 (Android 5.1.1). Bought in 2015, so AFAIK warranty just run out (hm, suspicious).

  • Note: After having posted the question I've reached out to Wileyfox support. Surprisingly I already got an answer about an hour ago, asking me to send in the device for them to check directly. Need to check warranty state etc. first of course. Will update details / answer the question as soon as I've obtained sufficient information. – Izzy Oct 19 '17 at 16:09
  • 1
    As you've already searched for QHSUSB_BULK, I take it for granted that you know your phone is bricked, and its bootloader has been damaged. That identifier stands for the Qualcomm 9008 emergency mode, which is used for flashing firmware. – Death Mask Salesman Oct 19 '17 at 17:03
  • @DeathMaskSalesman thanks for confirmation – and yes, that was my (temporary) conclusion. But as you write (which again confirms my findings) it's "used for flashing firmware", I was hoping to be shown a way to do so and, in that process, fix the bootloader. // What I completely fail to grasp is how the bootloader got damaged tonight. I didn't fiddle with it – the device still has its original firmware and all. Last "flashing stuff" was done more than a year ago (TWRP), and there have been several boots since. – Izzy Oct 19 '17 at 17:08
  • cough time-bomb cough. Aside from the speculation, I'll suggest you to search for xda qfil, as the flashing procedure is the same for every phone in such condition. The catch is, that many malware disguised as Qualcomm tools is around, so tread carefully. I'll see if I can dig up something, but I'm not familiar with the toolkit either. – Death Mask Salesman Oct 19 '17 at 17:11
  • Thanks again, @DeathMaskSalesman – I'll check that and report back. But if my warranty is still up, I might be better of accepting Wileyfox' offer of sending the device in; at least, if they break it they know how to replace it :) Funny thing with "canned blocks": They suggested I should back up everything before sending it in. Wish they'd explained how to do that with the device not even booting up :) – Izzy Oct 19 '17 at 17:16
1

We received your device and were also not able to get it back into normal boot, so we changed the PCB (mainboard). Your device will be returned today.

Though we strongly want to advice you to accepted the FOTA update to Android 7, as CyanogenOS (we flashed the latest CyanogenOS, Android 6 version, namely ZNH2KAS7EB on your device) is no longer supported and you are running an Android version with security patches from 2016. With this software, your device is vulnerable for several security issues like the Kracken WiFi (patch is coming) and the Blueborn Bluetooth (patch already available) vulnerabilities.

But besides that, some recently updated applications (Facebook, Spotify, Instagram) from the PlayStore are conflicting with CyanogenOS and causing the phone to freeze/crash and eventually the phone will get in a bootloop where you won't be able to get out of, unless you manually flash your device to Android 7 through the recovery.

If you decide to not accept the update to Android 7, we can no longer help you in the future in case of warranty claims.

With regards,

Team Wileyfox

  • Thanks a lot for the detailed feedback! The apps you've named are of no concern to me (I'd rather remove them than using them) and I'm aware of the security issues you've named (BT is turned off permanently anyway, and WiFi only used in "restricted environment" – same for most of the other CVEs you didn't name explicitly). As soon as the underlying "stuff" keeping me from N is solved, I'll of course update. Thanks for your great support and for Wileyfixing my device! – Izzy Oct 26 '17 at 12:14
  • @Izzy How time flies. Wileyfox is reported to be on bankruptcy (Feb 2018). – iBug Feb 11 '18 at 14:08
  • @iBug yeah, I heard. Sad. All just looked that promising. Let's cross fingers and wish them the best – not all lost yet! – Izzy Feb 13 '18 at 7:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.