1

It happened when Google Play was automatically updating apps. I guess, something went wrong and the phone suddenly restarted and was not able to turn on again. It always gets stuck on "Starting apps" screen and then restarts again (bootloop). I figured out, that if I can delete the app causing bootloop it should be just fine. However, I don't know how I could do it.

My phone is nexus 4 running Android Marshmallow. Also, I have a custom recovery (cwm 6.0.4.7). So, I tried to connect through adb to the phone in recovery mode and delete the app, however, I can't use any adb command, because "device unauthorized". I assume, as soon as I can get access through adb, I can delete the app.

After surfing many forums for the past several hours I couldn't able to find any solution which preserves data the phone has. Any ideas how I can delete/fix the app without loosing any data? (nexus 4 doesn't have SD card slot). Thanks.

P.S. wipe cache partition didn't help.

  • Didn't know CWM offers ADB access (TWRP does). But have you tried, from CWM, to delete the cache? That might already do the trick (not guaranteed, but worth a try and doesn't destroy any data). – Izzy Nov 3 '17 at 7:59
  • Yes, I did "wipe cache partition" and "wipe dalvik cache", it didn't help. If I change my recovery to TWRP, will it help? I think I will still stuck with "device unauthorized". – Rustam Nov 3 '17 at 9:10
  • You could try fastboot boot twrp.img (that would just boot it once without making changes to your device – at reboot you'd be back with CWM) to find out. As I've just done so with one of my devices returned from repair (PCB replaced), I can report there was no "unauthorized" but it simply worked "out of the box". // Please let us know the outcome then. – Izzy Nov 3 '17 at 9:58
  • "FAILED (remote: not supported in locked device)". My bootloader is locked, and unlocking it will erase all the data. Well, I guess I have no choice except wipe the data. Thanks! – Rustam Nov 3 '17 at 11:24
  • Umm, well, if you re-locked the bootloader after flashing CWM, that's probably the only option left. But before that: If you have a Linux machine, try running adb as root. It might well be it's not the device rejecting the connection, but the PC refusing it. Had that once. – Izzy Nov 3 '17 at 11:51
0

I just faced and fixed exatly the same problem on my Galaxy S3 I9300 with Android 6 Marshmellow (bliss 6.1 rom). Bootloop happend without any warning at the Night of 31st to 1st November. Just saw my phone rebooting ever and ever. Over the last 5 days I tried to get it back working or even to get some more backups out of the twrp backup.

What I found was: I got it running with factory reset and right after installing either of them: telegram, davdroid, the phone crashed directly in the appstore while installig. Then the phone rebooted and got stuck.

Important: you should make a twrp/nandroid backup if you not already did. a lot of reading, testing and questions in xda got me that far and this link here finally brought me to the ida: TWRP backup - Can I restore some app data without restoring the whole image?

initial Idea: extract all neccessary /data/data and data/app subfolders of your apps in the system and restore them to a clean factory reset. This worked not perfect but I got it running to access some more data as before. I did the copy or delete of the app folders through twrp -> advanced -> file manager.


Update: After I later got another(quite simple) idea on the base of initial guest post: why not going the way in the other direction and removing apps in the broken installation. This did the trick perfectly. I finally got into my broken rom again, all remaing apps worked as before (quite important to me since encrypted apps like threema and signal are not just copy-data-backups). Right now I am doing backups of my old Android 6 system :) for the import in my new Android 7 setup.

Hopefully it works for you, too!

OK now step by step what I did:

  1. be sure to have a twrp backup of your device (efs,boot,system and data) and to have your broken system installed and not factory reseted.
  2. then in twrp got to advanced -> filemanager and navigate to systemfolder. there delete all unneccessary apps by deleting the appropiate folders in /data/app and in data/data. This will "uninstall" the apps. These will not be optimized or loaded when you boot up. I especially deleted Telegram, DavDroid since I knew out of my checks one of them was causing the error. but i just deleted more apps that I do not need a backup or which are less important. For me this did the trick! Even better this can be done 1 after 1 if neccessary. I first tried this with all apps -> again bootloop. Tried it again with less apps -> worked. So its likely not the system its directly a app in the optimizing/starting process killing the bootprocess.
  3. just to be sure clear cache and dalvik cache to be sure android is reloading the changes and not seeing and cache
  4. then go for a reboot to system (Fingers crossed)
  5. if your're able to boot in again, then imediately open google play store -> scroll down to settings and deactivate automatic update of apps ( Just to be sure not getting any update causing a crash while you are inspecting your data, making updates and so on)
  6. finally i would recomend thinkig about moving on to a Nougat rom (if available for you). It's likely that there will not be an update soon fixing this bootloop problem (even if its unclear what caused it or which app(s)). I choose ressurection mix since its a quite active project and frequently updated.

best luck to you guy, I know how hard this problem hits.Alex.

(Guest "Alex." and me are the same author -just forgot that I already have an account).

  • Thanks, but I already rolled back to stock ROM (android 5.1.1). Many users of custom ROMs faced the same problem in the beginning of November. In my and your case it was caused by Telegram, however other apps have the exact problem. According to some forums, it is related to the release of new Android Studio and something related to AAPT2 (didn't investigate this yet). So, I guess soon my custom will crash more and more when developers migrate to new Android Studio, therefore I've decided to use stock ROM. – Rustam Nov 5 '17 at 6:12
0

You're right, since I more and more focused to this I found the confirmation regarding DavDroid. Telegram I found some discussions, too but no official statement.

Here's what they say at DavDroid: Version 1.9.2 (November 4, 2017):

build tools 27 works around bug of some custom ROMs that causes crashing apps and boot loops

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.