0

I got a problem with my Samsung device and now I've no idea how to fix this, hope anyone want to help me in fixing this problem.

So this thing started yesterday when I just went in to Recovery Mode to "Wipe Partition Cache" and turn my phone off. 1)When I tried turning my phone on, it doesn't go to normal boot but it go to "recovery boot" I dont't know why, restarted, unplugged the battery and turned on my phone again but it won't make my phone get out from recovery boot.

2)Now I'm trying to flash my phone with Odin, when I tried to flash it says "There is no PIT partition", "There is no PIT Binary", how to fix this ? I've tried to download and used the pit file but it didn't worked.

please help

0

You can only get out of this if you were on custom recovery where you shall look for the official boot.img of the phone and flash it into the recovery partition. There it will boot. If you're sure the boot partition is not damaged, you can use the dd command to extract it. In simple. Using TWRP Terminal:

dd if /dev/block/[msdcblockname]/by-name/boot of /sdcard/boot.img

This will dump boot.img at internalsd. Use it to flash the recovery partition. Note: the folder reffered to as msdcblockname above varies with device so research path to boot for your specific phone model.

But anyway if you're on stock recovery, either get a full OTA package that is made for full system update, not the incremental one ADHD flash it by apply update from sdcard or ensure the ROM you downloaded for Odin is specially for your device model and it has all items in it. Because Odin is the only hope you're left with

  • Do you have Line ID so i can contact you easily, bcs its hard to communicate here – Jack Kamikaze Dec 8 '17 at 13:45
  • @JackKamikaze just create an account on this minisite cutefox.wapka.mobi/messages_0.xhtml, send a message containing your number to: ThallyAce. I'll get it and get to you. I only use WhatsApp. Notify me here for a check on it there – Thally Ace Dec 8 '17 at 17:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.