I'm trying to provision a Huawei Y6 (MYA-L11) with a custom Device Owner app via NFC after a factory reset. However, once it has downloaded the admin app, I get a message box: "Oops! Couldn't install the admin app." and the only option is RESET which repeats the factory reset.

I have tried this method with a Motorola Nexus 6 without any issue. I have also been able to install third party Device Owner apps (e.g. SureLock) via NFC in this way on the Huawei Y6; the issue seems to be with custom apps.

I have also tried provisioning the sample apps in this way without any success. Is there something I'm missing from my apps and the sample app that third party apps aren't?

Provisioning the device manually works but I'd like to make the process do-able by non-technical staff. Manual provisioning can be done by going through the initial set-up process, skipping anything that can be skipped. Once set-up is complete you have to turn on Developer Mode in the settings, turn on USB Debugging, install the app via ADB and then set the Device Owner via ADB to the receiver specified in the app manifest. Waaay too complex for our non-technicals.

  • I've run into the same problem. Did you ever find a solution? Commented May 30, 2018 at 15:32
  • No, we just went with doing it over ADB.
    – Alex Meuer
    Commented May 31, 2018 at 16:59

1 Answer 1


Had the same problem and it was because the App I was trying to install was self-signed. I signed it with a real certificate and then the problem went away.

It should also be noted, that I'm using QR codes instead of NFC as the tablet I'm working with does not have NFC.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .