1

This may look like it's beating a dead horse, but it's not.

All of my Android devices of different brands and different chipsets, from Exynos, Snapdragon 820, Snapdragon 435, with stock or custom ROMs, AOSP-based and manufacturer-based ROMs, all fail to download apps on a fully functional WiFi connection that has no problems with accessing every possible resource that I ever needed.

Updating/Downloading apps fails with Error 495. I had done everything I could to mediate this, but since this is happening on all of the devices that I tried, with more than 1 Google account, it's safe to say that it's not the device's fault.

The fault is in the Downloader app (the one that downloads the apps for Google Play), in communicating with my Asus RT-AC66U router with Asuswrt-Merlin on it. Everything else works fine, including when I connect to another WiFi hotspot on the exact same internet connection. But it also doesn't work if I connect to a WiFi repeater that's hooked up to the same problematic WiFi hotspot on the Asus router. (Both the 2.4 and 5GHz hotspots fail)

Rebooting both routers, and making them go a power-off/on cycle, had no effect. Unhooking the repeater off didn't help either. As I've said, everything works fine. Other WiFi devices on the same hotspot have access to HTTP, HTTPS, with no reported broken keys that would suggest a security risk or anything. I didn't change any settings, and updates used to work just 4 days ago.

So the question is: What is so special about the Downloader app, or about Play store, that makes it the only thing that's failing?

Or how can I diagnose this? Maybe an easy to use packet sniffer that's able to show the failing request and allow me to reproduce it outside of my phone, and figure out what exactly about my router's settings it doesn't like. I promise to share my findings, and will describe in detail every step that I took, if it helps me fix this issue. Because right now I don't even know where to start looking.

  • Have you seen What is error code 495 on Google Play and the YouTube app? Can be found in our nice google-play-store tag-wiki, in case you need another error code in the future :) – Izzy Jan 18 '18 at 20:45
  • 1
    I've gone on xda-developers and around 50 sites and forums and everything android-related, tried pretty much every trick in the book. The problem is that after going through every single settings in my router and turning off every non-vital feature, and everything that can be changed without breaking it, I finally got it to work. And the solution was indeed not in the phone, or the account, as pretty much every single description of the problem tells. The bad thing is that the actual solution got zero attention. I'll post my answer below. – AlexanderMP Jan 18 '18 at 20:58
  • maybe its a dns problem try resetting your router – Tech XD Killjoy Jan 18 '18 at 23:54
2

Lucky for me, my router has a connection log, that I could look through. From my phone that was trying to download an app, there were many connections, but these brought up my interest:

tcp   192.168.1.174:51959                      52.15.96.207:443                         SYN_SENT   
tcp   192.168.1.174:51974                      52.15.96.207:443                         SYN_SENT  

Indeed, the remote IP did not respond. But the feature worked on other access points. I decided to change the DNS settings in the DHCP server, from the ones provided by the ISP, to OpenDNS.

https://en.wikipedia.org/wiki/OpenDNS

This can also be done from the phone, from the advanced WiFi connection settings, when you choose something other than DHCP.

That did the trick.

As mentioned by What is error code 495 on Google Play and the YouTube app? too. Please, if this solves your problem, go upvote, so that it doesn't sit on the bottom of the answer list.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.