I tried downloading apps from Google Play Store via WiFi, but I got error 495.


I tried all the steps like:

  • Clear cache data from the Play Store app
  • Delete Google account and recreate it
  • Factory reset
  • Rebooting device.

I assure you that the problem is not with the device. It has lots of memory space, so it's not error. And apps can be downloaded in mobile data. I followed the steps which are provided on the troubleshooting page for "495". But no luck.

Anyone gives me a clear idea of why the apps are not able to download via WiFi only?

  • It appears that we have many questions for which this question can be marked as duplicate: android.stackexchange.com/search?q=495.
    – Firelord
    Jan 21, 2016 at 9:55
  • @Firelord, I agree with you. But none of those solve this problem. That is why I raised a new question. And for you information I referred many things before posting question here.
    – ajantha
    Jan 21, 2016 at 9:59

4 Answers 4


I faced this same problem a while ago. I could think of two things here.

1. In my case, I had problem with my router. Other devices connected to the same router had no issues. I had to reset the router and everything worked fine after connecting the device back to it.
2. Then, you say you have 'Clear cache data from playstore app' but have you cleared the cache of all applications? try something like 'cc cleaner'. May be some old installation files/folders of the app you are trying to download, in this case chrome browser, might be causing this problem.

  • Thanks for your response. I will check with router. And its not for updating the app alone , I coudnt install new apps from Play Store too. Anyway I ll try your router suggestion .
    – ajantha
    Jan 21, 2016 at 9:53

I disabled IPv6 on my router and that seem to have resolved my issue.

  1. Force stop Google Play Store from Settings and clear the app's cache.
  2. Force stop Google Service Framework and clear the cache.
  3. Reboot Phone.
  4. Check if the problem persists. This should do.

Even I faced the same problem while using WiFi

U can try these

  1. Restart the router
  2. Restart the device
  3. Contact ISP
  4. Going to settings and uninstall the updates of play store. As it is a system app, you can revert back to latest version after sometime

Hope it helps

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .