0

I installed TWRP in my rooted Sony Xperia L using the TWRP Official App. The app said that the flashing was successful. Then, when I give adb reboot recovery command, it boots into the stock recovery. Even when I try to reboot into recovery from the TWRP Official App, it boots into the stock recovery. There is no TWRP whatsoever. Even when I try to boot with the hardware keys and/or fastboot, it either shows a blank screen with the blue notification LED ON or boots into the stock recovery. Please tell me what to do...

  • The Xperia L is one of the weird ones that utilizes the Fota partition. The stock recovery has an in boot arrangement. you using the stock kernel or boot image? If yes then does your stock boot image include ramdisk extraction utility? You might need some extra steps to get TWRP installed. What detailed steps did you attempt when trying to install TWRP? – Bo Lawson Jan 12 at 1:33
  • @BoLawson I tried installing TWRP with the TWRP app as well as with fastboot . Also, I'm pretty noob to this FOTAOKerne thing. And yes, I'm using the stock boot image. What is ramdisk extraction utility ...?l – Vishal Krishna Jan 12 at 1:35
  • It is way to extract the ramdisk from the FOTA Kernel partition using the ramdisk from that partition. This allows you to have TWRP boot from the FOTA Kernel partition instead of the recovery that is included in the boot image. Pretty much you need either a custom kernel with TWRP inside, custom boot image, or stock kernel and boot image that can utilize the Fota Kernel partition for TWRP. The Fota partition was ment for OTA's but since custom firmware and it a do not mix. TWRP along with Free Xperia developers decided to utilize no longer device useful partition to have TWRP reside in. – Bo Lawson Jan 12 at 1:53
  • What android version? What version of TWRP are you trying to install? What fastboot command did you use specifically where did you try to flash TWRP with fastboot? You might have to flash a custom rom first in order to support the fota kernel way. It is rare but some stock kernels might support the Fota way. Options: flash a custom kernel which has TWRP inside, install cm/lineageos then use the app to install TWRP, use Other boot images including stock kernels can be repacked to include this extraction utility to allow you to use TWRP from the FOTAKernel partition possibly a tool – Bo Lawson Jan 12 at 3:49
  • Android Version: Jelly Bean. I tried installing using fastboot flash recovery TWRP.img. Also, I was trying to install Lineage OS [7.1.1] from TWRP. I just wanna install Lineage OS. That's my ultimate aim. If I can actually do that without Installing TWRP, I just want that to happen. So, is there any way to do that..? I don't know how to install Lineage OS without TWRP. – Vishal Krishna Jan 13 at 3:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.