I developed an app for android. I used my two devices (Galaxy Nexus running 4.02 & Galaxy Tab10.1 running 3.1) to test the app before I published it.

When I published the app to the Market, I removed the tested version of the app from my devices and tried to install the one in the market but I couldn't install it !

In my Nexus device, It gives me this error: *"App_Name" Could not be downloaded due to an error (500).* In my Tab, a progress bar is shown then disappear with no error message.

To solve it, I tried:

  • Rebooting the devices.
  • Removing my Google account from my Tab and re-adding it again. the problem still exists.

I can install other apps with no problem. If you think the problem is from my app, try installing it. Search for "Untiny" in the market


4 Answers 4


The app works on other devices according to the user reviews. Perform a factory reset on your device and see if the error occurs while installing


I have had this problem before and tried everything, including hard resetting my phone. I forget what worked, but I think going through the web version of Market helped.

I had tried restoring a backup previously of a previous version of the app. This may have caused the problem but it doesn't explain why several apps have failed on auto update this time. I use Vodafone, and the service is not that good, so maybe the apps are getting corrupted.

Thinking about it might have contacted android support on web market place and got a resolution there after a few goes. So the thing about google fault see them, last time might be the only valid answer. I also have the error on new installs to, I have discovered. So it is likely some corruption between the app configuration on my phone and the market. Google should have had a method to fix this, if only by reinstalising the data. As I said before I waited 1 to 2 minutes for it to clear, it did not, so contact them quickly.

  • 2
    Your commentary regarding the previous edit is completely unnecessary and incredibly inappropriate. If it failed to capture the meaning of the post then you're of course free to fix it up however you want, but the there were many grammatical and spelling errors in your original post, to the point that it was literally difficult to comprehend what you were saying. Commented Apr 28, 2012 at 2:13

Turns out that the app didn't upload completely! Something went wrong while I was uploading it to the Play store.

It installed just fine after I uploaded a new version.

Thanks to all.

  1. Go to recovery => wipe cache
  2. Go to advanced
  3. Wipe dalvik cache
  4. Fix permissions
  5. Reboot

Source: http://androidjinni.com/google-play-store-error-500-solution-2353/

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .