Today I got brand new Cubot GT-99, added my Google acc but when I try to install any app it throws error:

"Some App Name" could not be downloaded due to an error(403)

Also app update throws a bunch of errors:

Update for "Some App Name" could not be downloaded due to an error(403)

I tried factory reset, and even another Google account and it still doesn't work. Also, I tried clearing proxy settings, and still no results.

This is the only problem with this phone, everything other works excellent.

Any help, please? Thank in advance.

  • 1
    I am having the same issue. Got a new Phone today (Moto G) and cant install any Apps. Internet-Connection is up, factory-reset does not help. I use the same SIM as in my previous phone and (Browser-)Google seemingly doesn't know that I upgraded, yet. Although my new Phone is mentioned in the market (on the web), the "installed" and "install"-buttons still refer to my previous phone. Is that the same on your end? Commented Feb 11, 2014 at 20:56
  • It's not the same, but the problem is definitely is. Maybe some temporary problem with Google Play for newly added phones.
    – xZero
    Commented Feb 11, 2014 at 21:21
  • @Omphaloskopie That's supposed to happen.
    – user24200
    Commented Feb 11, 2014 at 23:21

5 Answers 5


It seems there is a problem with Google play.

Please take a look at the issue tracker.

  • 1
    From twitter feed now, saw that a few are experiencing the issue as of right now. It is nothing to do with devices, there's something b0rk3d on their end....
    – t0mm13b
    Commented Feb 11, 2014 at 21:44
  • That's so true. After reseting options to default in APN settings it works. But sometimes a problem occurs again.
    – xZero
    Commented Feb 11, 2014 at 23:15

Got it!! (just had the same problem after updating from 4.3.2 to 4.4.2)

  1. go to settings - Apps - All - and open Google Play Store
  2. Click on "force Stop" then "clear data" then "clear cache"
  3. Go Back to settings - Accounts - and remove account and add it back again (available for KK) or change it to the same actual password
  4. Open market place and install a brand new app (never used before) and then install and update every thing you need :)

i9100 - CM11 KK 4.4.2
gapps- kk- 20140105

  • Won't work for the OP, as a factory-reset should already have done this :(
    – Izzy
    Commented Feb 12, 2014 at 0:11
  • it's all about the procedure!!! <br>It worked for me, have you try it?.... because i re-downloaded and reflashed my phone without success... but this process did work!!!
    – user53460
    Commented Feb 12, 2014 at 0:15
  • Why (and how) should I try it? I don't even have that problem. As to your steps: 2) a factory-reset clears data+cache, sure. 3) a f-r removes the account (user has to set it up after next boot). 4) is the only thing that could have triggered anything – so that might be something @xZero might wish to try.
    – Izzy
    Commented Feb 12, 2014 at 0:21
  • dude, if you dont have the problem just stand down... this is a validation problem regarding time format and handshankes. If you reset it you will be forced to go trough the wizard that will set up your phone and eventually will generate you this problem.
    – user53460
    Commented Feb 12, 2014 at 0:23
  • If only people having the problem are allowed to answer, we'd probably drown in unanswered questions. No more discussions here, and check what you "suggest" (and whom ;)
    – Izzy
    Commented Feb 12, 2014 at 0:26

Download .apk file of google play from here. If your device has the option, first select 'Uninstall updates' from your app manager for google play app. Then install this .apk file and then try using it. (You should also remove your google acc before uninstall/install). Let me know if this worked!


Just a note to help someone else with this on a Samsung S5 LTE

could not be downloaded due to an error. (403)

Everything was going great with my brand new S5, until I turned on the Download Turbo. Note, prior to turning on the booster, I was installing apps successfully over a WiFi connection.

I turned on Download Booster hoping to install apps from previous phone quicker. Natural enough thing to do when you have 30 apps to get through, wouldn't you think?

All of a sudden I couldn't download anything from Google the Play Store.

Oddly, The Galaxystore (a wierd extra Play Store that comes with Galaxy Phones) worked, but most of my apps were not there, and those that were did not know I had purchased them.

After perusing the web, and resetting things and changing Google accounts, etc., I finally tried turning of my WiFi connection, and switching to only 4G mobile data.

Of course the S5's Download Booster was off now.

As if by magic, everything in Google Play Store started working again!

Okay, so maybe something in the Download Booster tries to make multiple connections to the Google Play Store server, and it doesn't like that.

So I turned off Download Booster, and turned on the WiFi, and turned off the 4G mobile data connection. Back to plain WiFi, as per the data connectivity configuration that was working in the beginning...

Alas, Google Play Store would not work again (same error), even with only WiFi on now. Back to 4G, switch off WiFi, everything works on Google Play Store again. Consternation!

In summary:

If you have an S5 and you turn on the Samsung 4G + WiFi Booster and connect to Google Play Store, kiss your connectivity to Google Play Store via WiFi goodbye forever. You can still connect with just 4G Mobile Data (as long as WiFi is off).

It's almost as if the Google Play Store server remembers indefinitely that you once tried to connect with WiFi and 4G together, and forbids your WiFi connectivity henceforth.


Remove google play store from the multitasking menu and try again

  • An error "403" is the response code of the server (access denied). So as t0mm13b wrote, it's an issue at Google's end. Nothing you could fix from your device. As the OP did a factory-reset (read the question again), there's no logic in your suggestion, sorry.
    – Izzy
    Commented Feb 11, 2014 at 22:28

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .