1

Today I had a bad idea and decided to try to install Gcam on my A2 lite. So I installed ADB and Fastboot on my PC (linux), then flashed TWRP with the aim of later installing Magisk.

However, something went wrong: whenever I switch on the phone, the phone has consistently not booted to Android, but only to TWRP (which however was working). So I panicked and tried to fix this issue via fastboot, but things did not improve; in fact, they even got worse, as now the phone is unresponsive after TWRP's splash screen.

The only things I can still actively do are shutting the phone on or off, and starting fastboot instead of booting the system (which amounts to booting TWRP after all). Once connected the phone to my PC with a USB cable, ADB does not see the phone, but fastboot does.

I've tried a few things already, including flashing TWRP again and flashing a new system.img I've downloaded from the Xiaomi page, but with no success; Is there any chance to save my phone?

(I've tried to use a Linux porting of MiFlash, but with no success, either).

  • May i know how you tried to flash system.img – helper Jun 4 at 16:00
  • 1
    but how did you flash it? did you use fastboot? – helper Jun 4 at 16:12
  • 1
    To be hones, I can't remember. But I've to do it once again, right now, and the outcome is: ... FAILED (remote: unknown command) finished. total time: 0.020s – Delio Mugnolo Jun 4 at 16:25
  • 1
    please try running fastboot reboot – helper Jun 4 at 16:45
  • 1
    Let us continue this discussion in chat. – helper Jun 4 at 16:57
2

Get the system.img from here: http://en.miui.com/getrom-354.html and flash it

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.