I flashed a MoDaCo ROM this afternoon just to try it on my LG Optimus 2x P990, which was on ICS (CM9). I see that it's based on the offical LG Optimus 2x ROM, but I decided to flash it back to Android 4.0.4 ICS again, the one I was coming from.

But I can't get into ClockworkMod Recovery. I didn't find ROM Manager on my phone after flash (it works, except for Market and has very many bugs), so I reinstalled it by sending the *.apk to my email. I installed CWM successfully, but I can't get into it. I have tried the volume and power button method and reboot from ROM Manager. None of them worked.

My phone does works (call and such), but I can't get into CWM, which is really annoying.

  • A successful flash of CWM should boot you into CWM, so how do you know it was successful? Commented Apr 13, 2012 at 17:11

1 Answer 1


I fixed it by flashing ClockWorkMod and the boot image manually. Then, I used the volume down and power buttons to get into it. Now, I'm running Android 4.0.4 ICS again.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .