I updated my Galaxy S2 with the official OTA update to Android ICS 4.0.3

After the upgrade, my wireless worked for a couple of hours, but after a restart it doesn't work at all (for a week now).

I tried a couple of tricks (none of them working):
1) *#*#526#*#* combination
2) WiFi Direct activation
3) Static IP
4) Changing to 2.4 GHz

None of them are working!!! Somebody has any other ideas?

BTW: I'm not getting an IP from my router. The router is working fine with other phones.

  • Can you try changing the channel? Also by not working what do you mean? You can't connect or you don't get IP or you can't browse?
    – roxan
    May 2 '12 at 16:08
  • i tried that. no luck. :(
    – Vlad
    May 2 '12 at 17:43

I was having the same issue for the last 2 days. After upgrading to ICS wifi was working but stopped working suddenly after a day. This is how it got fixed:

  1. selected the network and clicked forget

  2. turned off wifi

  3. turned wifi back on

  4. connected the wifi network again

  • tried it. no luck. it displays: "Saved, secured with WEP", but still no IP, no internet.
    – Vlad
    May 5 '12 at 9:12

From what I'm reading, it sounds like your best bet will be to reset it to factory defaults. That looks like it's fixing the problem for others. This will, of course, delete your apps, contacts, calendar, and a couple other things that escape me at the moment. Make sure that you have your phone set to back up everything with your google account, and I'd recommend using Titanium Backup to make a backup of all your apps.

  • That's what I'm trying to avoid. I've read that others reseted to factory defaults and had the same issue.
    – Vlad
    May 2 '12 at 17:55

There's a few things you could try:

  • Turning phone and router off and back on.
  • Changing the SSID of the network.
  • Changing the password for the WiFi.
  • Changing the encryption used on the router (ie. from WPA to WPA2 or the other way around, or even turning it down to WEP)
  • Changing the channel that the WiFi is using.
  • Turning off the password for the WiFi and trying to connect (don't forget to turn it back on later though).

I know some are fairly basic but I've had problems in the past connecting to my Virgin Media router and they've worked for me.

  • I know you are trying to help, but if you read the comments and the original post its clear he has tried all the basic stuff :)
    – Aadi Droid
    May 2 '12 at 18:29
  • He has said he's tried 4 things, none of which I suggested in my post, but I know what you mean. However other users might find it useful. The one I'd recommend trying the post is turning off the WPA2 (or whatever), so no password, and trying to connect then and seeing if you can.
    – Peanut
    May 2 '12 at 18:32

same issue I had. Only thing that worked for me is restarting the router and then connect back to router. But the issue is that there's no internet after 3-4 minutes maximum. and then go restart again the router and again 3 min of internet...

Not the answer you're looking for? Browse other questions tagged or ask your own question.