3

I have a PC whose name is "mypc". It's accessible on the local network.

https://mypc.local correctly displays its website when browsed from Mac, iOS, and itself.

However, using my Pixel 3 with Android 11, browsing to https://mypc.local says “This site can’t be reached”. ERR_NAME_NOT_RESOLVED.

Interestingly, if I remove the ".local" and try browsing just to https://mypc, the browser finds the host correctly. It says "Your connection is not private" and ERR_CERT_AUTHORITY_INVALID (which just means my self-signed certificate isn't configured to expect "mypc" because it expects "mypc.local").

I've tried Brave Private, DuckDuckGo, and Chrome.

How can I fix my Android devices to correctly use the .local hostname?

P.S. I've seen the following questions, but those answers don't apply to my case since my network router is correctly mapping mypc.local to the specific IP of that PC. Additionally, even Android is aware of how to resolve "mypc" to the correct IP, so I'm curious how to get it to treat "mypc.local" the same way.

P.P.S. I also just tried from an old Nexus 7 with Android 5.1.1. The results are basically the same as with Android 11. https://mypc.local/ does not work and says DNS_PROBE_FINISHED_NXDOMAIN. https://mypc finds the host correctly but says NET:ERR_CERT_AUTHORITY_INVALID.

13
  • Check the "secure DNS setting". If it is activated your local DNS server (e.g. in the router providing the .local addresses) will be ignored and instead a secure connection to a DNS server by e.g. Google is used. Of course this DNS server knows nothing about your local devices.
    – Robert
    Oct 29 '20 at 19:06
  • @Robert My router is the AT&T gateway Arris BGW210-700, which does not seem to have any DNS settings in the config or even mentioned in the PDF of its manual. Are you saying there is a "secure DNS setting" within Android 11? I searched but couldn't find it. Thanks for your help.
    – Ryan
    Oct 29 '20 at 19:12
  • 1
    @Ryan I can't be very specific in your situation. Your question is more about troubleshooting than a precise answer. Make sure your DNS traffic isn't encrypted. Secondly force it to go to your router by using iptables (if rooted) or VPN. Then use dig on Termux to see what response your DNS query gets back. This should certainly lead you to some conclusion. You can follow any DNS troubleshooting guide. Android-specfic things are explained in my previous answers on the subject. Nov 3 '20 at 10:30
  • 2
  • 2
    @Ryan - Yes. That's the one.
    – Sonny
    Nov 12 '20 at 0:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.