1

I just upgraded from Oreo to Pie, and calls are not working. Everything else is perfect.

Completely mute: I can't hear anyone, and no one can hear me. Not even voicemail works

  • Whatsapp call works
  • Tried wiping the phone app
  • Tried that option to erase Wi-fi, Bluetooth, and Mobile network settings
  • Tried soft reset (hold power for 10s)
  • Tried manually selecting the carrier
  • Tried cleaning the handsfree jack (no use, since whatsapp calls and hardware tests show that the mic and earpiece are good)
  • Tried replacing the phone manager by another
  • Tried call via bluetooth

Tested side-by-side with another phone I have. Completely mute.

This is the ROM: https://www.stockrom.net/2019/07/xt1925-5.html/amp

All well in according to the model (XT-1925-5)

Is there a way to determine the cause ? Is there a FIX fix ?

Apart from Hard Reset, of course. That would be the third time this month I do that to fix glitches... Problem is that every hard reset forces me to visit two banks to enable the phone.

2
  • 1
    I would try to "reset" the mobile network part of the phone by removing the SIM card, reboot, reinsert it and reboot again. Modern phones do provide features like VoLTE and WifiCalling which depends on a lot of software settings, may be one of those wasn't correctly upgraded. Hopefully reinserting the SIM card forces the phone to reapply the necessary settings.
    – Robert
    Jun 12, 2022 at 10:29
  • Hello, Robert. Tried now, but didn't work. Your idea also led me to another: Reset Wi-Fi, Bluetooth and Mobile network configurations (that option is under the phone's advanced settings), but didn't work either. The problem lies deeper, aparently. I'm thankful for your suggestion.
    – Lucas BS
    Jun 12, 2022 at 14:49

1 Answer 1

0

I surrended and reflashed the ROM (again), and it worked.

Don't know if just hard resetting was enough. I skipped that.

Plus, I used another ROM source: https://motostockrom.com/motorola-moto-g6-xt1925-5

Don't know if that made a diffence or was unnnecessary.

Well... Works now

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .