1

I have an Android 12 with MIUI 13, Xiaomi Redmin Note 11 pro 5g.

sdcard works flawlessly, configured as an removable/external memory.

I reboot the phone, and it asks me if I want to use it as an internal or external memory (portable). If I choose external, the only option I have is to format it and loose all my data.

This is a lot of overhead: copy old data, reformat it and copy again backup up data.

I already hat to do so when I upgraded from MIUI 12 to 13.

I don't desire to do this every time I reboot the phone.

Any hints to avoid all this fuss?

I've checked with fsck that the partition has no problems.

Related info:

UPDATE

Finally I've decided to:

  • backup all my data
  • format the sdcard with the phone
  • extract the sdcard
  • recopy all the data (a very lengthy process with a 128 Mb card)
  • reinsert in the phone

and now it offers me to format it again in order to use it.

 sudo fsck.exfat /dev/mmcblk0p1
[sudo] password for david: 
exfatprogs version : 1.1.3
failed to get stream dentry. 0
failed to get name dentry. 0
failed to get stream dentry. 0
/dev/mmcblk0p1: checking stopped. directories 405, files 1562
/dev/mmcblk0p1: files corrupted 3, files fixed 0
3
  • 1
    So you want to use the sd-card as external. Have you tried to remove the card for a reboot? Have you tried to overwrite the first few MB of the card with zeros. You need a PC and an USB sd-card reader to do so (or a rooted phone).
    – Robert
    May 5, 2023 at 13:05
  • Thanks. What is the procedure for overwriting the MB?. I have a PC and a sd card reader. May 5, 2023 at 13:13
  • 1
    On Linux you can use dd command-line program. On Windows I would use HxD a simple free hex editor which is capable to open a whole disk, then select a block of a few MB and then overwrite it with zero.
    – Robert
    May 5, 2023 at 15:28

1 Answer 1

2

I've installed by compiling https://github.com/exfatprogs/exfatprogs version 1.2.0, as it can repair the filesystem.

Then I run in a Linux PC with a card reader:

$ sudo /usr/local/sbin/fsck.exfat /dev/mmcblk0p1  -p    
exfatprogs version : 1.2.0
...
ERROR: /Android/data/com.sygic.aura/files/maps: unknown entry type 0xc1 at 0000420 at 0x2c80420. Delete (y/N)? y
/dev/mmcblk0p1: clean. directories 414, files 3296
/dev/mmcblk0p1: files corrupted 0, files fixed 3

and now the phone accepts the sdcard.

I don't know why so many errors after recopying everything.

Maybe some Android app can do the same, and it will be more confortable to use, but probably it will need root access.

1
  • 1
    I tried with version 1.1.3. It failed. Version 1.2.1 worked.
    – Ole Tange
    Oct 19, 2023 at 21:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .