I am currently facing an issue with my Samsung Galaxy Tab 2 tablet running Lineage OS. Whenever I attempt to reboot the device using the adb reboot command through adb, it enters a strange hanging state - the screen turns off, and it becomes unresponsive to any further commands. It remains in this state until I physically unplug the USB cable, at which point the tablet restarts and functions normally again. Interestingly, during this state, the adb daemon fails to recognize the device, but lsusb still detects its presence. I have attempted to restart the USB port/device using usbreset,

sudo usbreset 18d1:4ee7

but within the dmesg log, I get attempts with several errors saying usb 1-1: device descriptor read/64, error -71 followed by finally with usb usb1-port1: attempt power cycle (full error output here). The terminal output is

Resetting Galaxy Tab 2 ... failed [No such device]

And the computer (in my case, a Raspberry Pi Zero W) does not recognize the Android device anymore until I disconnect the USB. I have tried restarting the RPi but still no luck, since I assume a complete "power cycle" would trigger it since it only operates after disconnection or reset of the 5V connection in the USB.

One hacky solution I have contemplating was creating a switch with the GPIO pins as a variant from this post, but I am still optimistic for a software-only solution before I start throwing hardware into the mix.

Here are some additional details that might be useful:

Tablet model: Samsung Galaxy Tab 2

adb shell getprop ro.build.version.release: 7.1.2
adb shell getprop ro.build.version.sdk: 25
adb shell getprop ro.build.flavor: lineage_espressowifi-userdebug
adb shell getprop ro.build.description:
espresso10wifixx-user 4.2.2 JDQ39 P5110XXDML1 release-keys

$adb --version
Android Debug Bridge version 1.0.41
Version 28.0.2-debian
Installed as /usr/lib/android-sdk/platform-tools/adb

Any suggestions are appreciated!

1 Answer 1


Well, I own multiple Samsung devices, but Samsung uses a custom boot process. It uses more like a custom uboot image than a standard Android boot process. Second, you will need a Samsung driver. From what I saw, you are using a Linux machine and Debian-based.

But I can see that you are using an Android 7 image. That device was shipped with an Android 4 system that could boot Lineage OS 10.

  • 1
    Hi, I tried editing this post based on my understanding since I can't understand the meaning of "y" used here (Is it a French pronoun?). If I accidentally changed the meaning, feel free to edit and improve it, thanks.
    – Andrew T.
    Aug 21 at 5:10

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .