I installed HAXM 1.0.4 and I cannot run Android emulator with option 'use host gpu' checked, it shows cyclic GL_* errors. I am using Mac OS X (mbp with NVIDIA GeForce 320M). Without gpu emulation everything works fine (well if word fine can describe that slow piece of software).

I have 8GB RAM, HAXM set up to use 1024MB. My virtual devices set up to use 512 MB (I have tried different values, but less then 1024Mb, according to HAXM doc).

Here are the error messages which are output periodically (emulator shows black screen) (complete log)

MediaProfiles(1113): could not find media config xml file
Zygote(1113): Class not found for preloading: android.widget.TextView$SelectionModifierCursorController$1

Zygote(1132): setreuid() failed. errno: 30
Zygote(1132): setreuid() failed. errno: 30
BatteryService(1139): usbOnlinePath not found
BatteryService(1139): batteryVoltagePath not found
BatteryService(1139): batteryTemperaturePath not found

I/sysproc(923): Entered system_init()
I/sysproc(923): ServiceManager: 0x8c01b18
I/SurfaceFlinger(923): SurfaceFlinger is starting
I/SurfaceFlinger(923): SurfaceFlinger's main thread ready to run. Initializing graphics H/W...

EGL_emulation(1139): rcMakeCurrent returned EGL_FALSE
EGL_emulation(1139): tid 1148: eglMakeCurrent(984): error 0x3006 (EGL_BAD_CONTEXT)
libEGL(1139): call to OpenGL ES API with no current context (logged once per thread)
libEGL(1139): call to OpenGL ES API with no current context (logged once per thread)
libEGL(1139): call to OpenGL ES API with no current context (logged once per thread)
libEGL(1139): call to OpenGL ES API with no current context (logged once per thread)
Zygote(1152): setreuid() failed. errno: 30

Also I tried to set LD_LIBRARY_PATH to <sdk install location>/tools/lib and that doesn't help me either.

They say "Make sure that your environment variables for the GL libraries are set correctly". How can I check this? Other programs are working well. Without HAXM GPU acceleration is working well.

Screenshot from emulator:

Screenshot from emulator

I should also add that errors occur only with Intel 2.3 x86 system image. With the newest 4.1 everything works fine.

  • When is the error shown exactly? How much RAM do you have? Dec 10, 2012 at 19:54
  • @MatthewRead Error is shown a few moments after I press "Start" button in AVD manager. Please take a look at updated answer, I added error log. I've also seen similar error messages on the web, however people got this error when emulator was already loaded and then were trying to launch some apps which requires ogl.
    – Nik
    Dec 10, 2012 at 20:22
  • Hmm, assuming those are from the emulator (rather than Android) you might want to try running it as root or seeing if everything under the emulator directory can be granted more permissions.... Dec 10, 2012 at 20:28
  • @MatthewRead still no effect (tried to run it this way: sudo ./emulator -avd Nexus_Intel_23) - emulator shows gibberish on the screen (inserted pic in question body)
    – Nik
    Dec 10, 2012 at 20:38
  • Wow, other than graphics driver problems I'm out of ideas but I don't know how those work on Mac (and it seems like there's more going on anyways). Dec 10, 2012 at 20:41

1 Answer 1


Why don't you try running it on a different OS? Dual-boot linux (probably Ubuntu) you'd be able to find much more info in the community forums and/or their official documentation. I doubt that this has to do with your device, more likely some missing dependencies on your host system. (sry, I wasn't "allowed" to add this as a comment :-( )

Additionally, in your last line of the question you mention that in the 4.1 image everything works fine, whereas in the intel 2.3 x86 image it does not. According to the documentation, graphics acceleration is supported in SDK Platform API 15 revision 3 (4.0.3) and higher. Assuming that your remark about intel 2.3 x86 and 4.1 refer to Android version 2.3 and 4.1, respectively, this would be in line with the android documentation.

Furthermore, take a look at the Android Project Issue Tracker for similar bugs and updates. There's also a pertinent question on StackOverflow with some useful suggestions and user activity.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .