I bought this tablet recently in Tenerife. Can find no information about the manufacturer.

Now the battery will not charge through the mains adapter. It did charge at first. However, I have found it does charge through USB connection to my PC. When it charged previously a light at the connector would be red. When it was not charging it would be green. It is red while USB connected.

Also it tells me now that it is charging, but if I remove the USB connection it stops charging. It has a screen showing battery condition in the form of a graph. I could see the graph of battery % decreasing gradually. A few days ago there was a sudden drop as if some App had used a lot of power.

I decided to remove all Apps and did a factory reset. This made no difference regarding the failure to charge. I have tried shutting down completely (hold the off button for a while and it asks if I want to power off)

This made no difference. Any advice please?

Edit #1: Thanks ce4 for your response. The charger is stated to be 5v and when I check it with a voltmeter, it shows 5.2v. Also I have tried pushing the plug into the tablet to varying amounts and makes no difference. Another point maybe I didn't make clear is that when I connect with USB only, the light does not come on but the device tells me it is charging.

But when I connect the power supply as well, the light comes on red as if indicating charging. But when I remove the USB leaving the power supply connected, the light goes back to green and is not charging from the power supply.

Despite apparently charging on USB, the percentage of battery left charged has not yet increased from 10%. I understand that USB cannot deliver high current. It appears you are right - something wrong with the charger - maybe it is not the correct one for this model - I guess it needs to be able to deliver power at a higher current level?

  • Wait, is this Spanish style plugs, they are on a different voltage to say UK/Ireland, try a continental adapter?
    – t0mm13b
    Apr 15, 2013 at 21:04

2 Answers 2


From reading what you have already tried, this sounds pretty much like a hardware issue failure. You may have:

  • a broken wall charger
  • a broken power plug or torn connection on the device side

Try replacing the charger or (in the latter case) pushing the plug a little (to see if it then reconnects temporarily).


Today I was able to load the battery to 100% after the PC was totally crashed due to low voltage. With a charger and a USB 5V/500 mA output (Carrera accessories for a helicopter) this has worked normally.

Through the USB connection to another PC, I had reached only 50%. The representation of the charge and discharge in the diagram is now understandable and I can use the PC to normal.

When using the main charging port with the same charger, burns the green light on the tablet and the battery will not charge.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .