2

I have a Samsung Galaxy S Advance and when I try to send a SMS message to someone I have to search through all my GMail contacts that for some reason appear on the app along with my phone contacts. I don't send mails through the message app and most of my GMail contacts are people who I sent just one e-mail in my entire life. The Sync and Account settings don't let me turn off Contact sync, just remove the GMail account entirely, and there is no menu in the messaging app that lets me hide the GMail contacts. Is there any way to make the messaging app only show the contacts I have on my phone?

1

In Android 4.1 Jelly bean follow the following steps:

  • Open the Contacts app
  • Tap the Setting touch button
  • Select Contacts to display
  • Select Phone

A similar procedure should work also for the earlier Android 2.3 Gingerbread.

0

I have note II. Here's my solution: in SMS, when you click create messaging icon, then click on phone book icon, you will see CONTACT tab listing everyone you have emailed and those in your phone book. Ignore that list. Scroll to the left to GROUP tab. Scroll down to MY CONTACT. It'll then show a list with the contacts on your phone (that is, you have already set your phone to display people with numbers only).

You have to manually do this every time but it beats seeing random people you have emailed. And you don't have to group or clean Gmail database.

Visual tutorial on how to do it: https://www.youtube.com/watch?v=vRvuSfTZ-1c

0

after following the steps above and still nothing happens. Go to phone settings>accounts>(click on your email)>left bottom>remove account> check your sms app contacts. Then if you want to add your email again, make sure when you add the account to sync off all.

  • I wanted to point out that EVEN AFTER following anne's steps above, the email contacts get re-added in the sms. This is because when adding an email account, it is synced EVEN WHEN sync has been turned OFF. So, AFTER the account has been added, sync stays off (if we have disabled sync before adding the account), but because the system REGARDLESS executes one round of sync WHEN ADDING the acco – Rey Aug 25 '18 at 4:58
0

open up the default text messaging app, click the three dots in a row and tap settings. Click general and uncheck "Show email address. That will stop your email contacts from showing up when you start a new chat.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.