2

On my Galaxy S4 (Sprint), I regularly get a voicemail icon in my notification bar with the message:

With this update, you will be able to enjoy premium Ad-supported features such as inline playback and auto forward to email.

I have no interest in "enjoying" these features, and I cannot figure out how to make it go away.

  • "Allow automatic updating" is not not checked.
  • I have no messages that haven't been listened to.
  • I do not want to disable all notifications from the voicemail application, as I would like to be notified when I have messages.
  • Clearing the notification makes it go away for anywhere from 5 minutes to a day, but it always comes back.

Sprint voicemail advertising garbage

Is there any way that I can disable this specific message?

3

Accept the update, it doesn't charge you unless you subscribe to the premium package. Aside from that, you could decompile the apk and remove the push notification for updates.

  • Are there ads in my voicemail app then? – Brad Jun 23 '13 at 18:27
  • Where to find this APK? I searched all my filesystem from top to bottom but didn't find VoiceMail apk. Can you say where it's located? – Suncatcher Mar 10 '17 at 22:11
1

I was able to remove the ads from my Sprint voicemail without root. On the Android device, go to Voice mail > Menu > Settings > Uncheck Display Ads.

Hope this works for you.

  • In what app is this? – AYS Aug 22 '16 at 14:30
-1

Please try the following:

  1. Android Settings
  2. Application Manager
  3. All Apps (drag page to the left)
  4. search your app and tap on it
  5. make shure, the box show notifications is unchecked
  6. Problem solved?
  • 2
    As Brad wrote: I do not want to disable all notifications from the voicemail application, this does not solve his problem (as it does exactly that: disable all notifications), sorry. – Izzy Jun 23 '13 at 10:45
  • hm, i see. this is what i did to ignore notification-spam of games etc... but to ignore specific notifications is not possible, i guess. Sorry this didnt work out. – zulu34sx Jun 23 '13 at 11:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.