4

I recently got an Samsung Galaxy S3, and I prefer the GMail app than the default mail client (the one with the red seal).

The default mail client seems to autocheck for email and displays a notification in the top left corner, but I can't get the native GMail client to do the same. Any suggestions on doing so?

5

Open GMail, and open its Settings. Click your username@gmail.com, and make sure Notifications is checked. Then, click Inbox sound & vibrate and click Turn Gmail sync on. Configure the Notifications at the bottom as you like.

In Settings, make sure Sync Gmail is also checked.

With regards to GMail sync frequency, see this question: How to set gmail sync frequency?

0

I had the same problem with my HTC oneM9. My Gmail would only receive emails when I manually entered the app and refreshed the screen. I googled how to fix and everything said sync Gmail, turn on notifications, delete cache and data, restart but nothing worked. Turns out my Battery optimization that's on constantly was preventing the push notifications. You can go into the power optimization and under the Gmail app you can turn off. This will allow your phone to remain is power saving whilst still getting your Gmail notifications. You can also set which apps you want i.e. Instagram, youtube etc.

Hope this helps!

0

After activating every Sync and Notification setting (per geffchang's answer), check if every label has notifications turned on:

  1. Gmail Settings
  2. your.account@gmail.com
  3. Manage labels
  4. For each label, click it and check both Label notifications and Notify for every message

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy