1

I have a brand new Google Nexus 7 (2013) LTE tablet and failed or enabling LTE on it.

I had two cards (microSIM for Nexus and nanoSIM for iPad Mini) from the very same LTE-enabled local (Poland) carrier Aero2. Both are inserted to respectful devices, both devices are in the same place (same network coverage) and iPad Mini catches LTE signal (and its amazing speed) with no problems, while my Nexus falls back to HSPA+ at most, only sometimes uses 3G and never runs on LTE.

Is there any extra switch on this particular device or Android system (was on iPad Mini) to enable LTE?

EDIT: Of course, I followed step-by-step guide on this subject available at Google Nexus Help.

  • 1
    Could you possibly contact Aero2 and see what LTE bands they operate in your area? While unlikely, it's possible that the Nexus 7 doesn't support your local LTE network. It seems like Aero2 uses 2500MHz, but that confuses me because I don't think the iPad Mini supports that band either. – dotVezz Jan 29 '14 at 20:32
  • I used another carrier's SIM card, which is 100% certified to be working on Nexus 7 and I still can't access 4G (LTE) network. My tablet's system has been upgraded to 4.4.2 KitKat in between, so now I have access to Settings > Wireless & networks > More > Mobile Networks > Preferred network type option. Whenever I set 3G there, tablet access network without problems. When I change it to 4G I can't access Internet. Tablet claims that, it is logged to LTE-kind network, but network is down. Now, I'm wondering, if my LTE modem is broken or if I'm outside LTE coverage area all the time? – trejder Feb 3 '14 at 10:21
  • 1
    Even if the card and network are 100% cerified for the Nexus 7, the carrier may not have the correct frequency available in your local area. Rather than asking "Do you support the Nexus 7", ask them "Which frequencies (or 'bands') are operational in the area with the postal code [your postal code]?" This applies to Aero2 and the other carrier as well. – dotVezz Feb 3 '14 at 12:51
  • Maybe you consider rephrasing all above comments to one answer (about checking bands in my area), so I could price your effort with some reps? – trejder Feb 4 '14 at 12:40
1

While unlikely, it's possible that the Nexus 7 doesn't support your local LTE network. It seems like Aero2 only operates LTE on 900MHz and 2500MHz (Take that with a grain of salt though; it may be incorrect or incomplete).

The Nexus 7 2013 apparently doesn't support either of those frequencies. Oddly enough, apparently neither does the iPad Mini.

You may want to contact Aero2 or whatever local providers and find out which frequencies (or "bands") they operate in your area. It doesn't matter if their network or SIM cards are "100% certified for the Nexus 7", they may not operate the appropriate frequencies in your area specifically. Rather than ask "Do you support the N7?", ask them "What LTE bands are operational in the area with the postal code [your postal code]?"

If your area should have a band that's listed on the GSMArena page for the Nexus 7, then you may have problems with your device. If not, then you may want to find a carrier that supports LTE on the appropriate bands in your area.

| improve this answer | |
  • Thank you for your answer. I'll only add for others and future reference, that after reading your answer I googled a little bit more and found information, that LTE on Polish Aero2 network has been available only as test-run, so now it is not available to any devices. – trejder Feb 4 '14 at 13:53
  • 1
    Another addition, after testing this Nexus 7 with another LTE-enabled carrier (Plus GSM, Poland): Though many carriers claims, that LTE network is enabled by default or on self-configurable, SIM-provided APNs, it many cases this turns out to be not true. So, there isn't any specific switch in Nexus 7, what I asked for, but certainly there could be a specific APN, that you have to enter to make your mobile device log into LTE network. If your device is unable to use LTE network, check APN settings at first. – trejder Feb 6 '14 at 20:16
-2

There IS a setting for LTE on a 2013 Nexus7 (1B32-4G). I just found it where you set up the Access Point Name (APN). Just go searching. I was surprised to find it. You have to click on a lot of selections to get to it in Settings then at the bottom of the first section called Wireless & Networks click on More. Click on Mobile Networks,then you will see Mobile Network Settings. in that menu list select Access Point Names (APN), you should see your network carrier such as "T-Mobile US" & under it mine says "epc.tmobile.com" that was already set up at a T-Mobile store when I bought my SIM card & registered. Then click on the dot to the far right to select your carrier so that the dot turns blue. Click on the name of your carrier on the left side of the screen, & on the new menu list, which is called Edit Access Point, scroll down towards bottom, BEFORE you edit or add anything, and click/select "BEARER". In that menu list, click & select the choice LTE. It may have been selected as Unspecified at first. Press the "Go Back" button, & as soon as you complete that the rest of the list of items in field called "Edit Access Points" fills in automatically for what you need, including the Name field, which in my case says "T-Mobile US".Close all screens as you're done. Now it's a matter of finding out if the right "bands" correspond to get the right reception. My own Preferred Network selections are limited to 2G &3G, even though it says "4G" on the label with the model name. That's another issue I'm taking up with ASUS right now as two supervisors told me that my model number is 3G/2G, but they also say that ASUS won't take care of the matter by giving me an actual 4G tablet which is what I paid for on amazon.com. Even though I now have the LTE setting corrected, it still says HSPA in Settings>About Tablet>Network Type, which I read is only 3G. I'm still baffled.

| improve this answer | |
  • 1
    If you've already found it, why not tell us where? Don't keep the answer to yourself! – Dan Hulme Apr 16 '14 at 6:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.