2

Is it possible to get the welcome screen again after going through it without having to wipe the device? I mean the screen where you pick language, configure your Wi-Fi, log into a Google account, etc.

I know all those things can be done from the Settings menu, but still, I want to get the welcome screen again, without having to factory-reset. The phone is rooted, in case it matters.

I want to make the welcome app start when switching the phone on, so I guess this might involve editing some config file which is read at startup.

2

EDIT: This probably won't work, because SetupWizard.apk doesn't have a launchable activity.

Although this question is almost a year old, others may still find this useful:

adb shell am start -n com.google.android.setupwizard/.SetupWizardActivity

I'm not sure why do you want to run the setup wizard on the next boot, though. If you want to give your device to a relative, why not do a factory reset, or if you want to keep the data on the device, just tell them to change things manually in the settings?

Anyway, if you're using a ROM with init.d support (such as CyanogenMod), create a new file called 00Asetupwizard with the following contents:

#!/system/bin/sh

adb shell am start -n com.google.android.setupwizard/.SetupWizardActivity

# "Self-destruct" to make sure the setup wizard is not reexecuted on subsequent boots.
# This may cause an issue if the device is rebooted before completing the setup wizard,
# but I don't know how to fix that.
rm -f /system/etc/init.d/00Asetupwizard

Then run the following commands on your computer, connected to your phone over USB:

% adb remount
% adb push 00Asetupwizard /system/etc/init.d/
% adb shell chmod 0755 /system/etc/init.d/00Asetupwizard

If adb remount gives an error, try the following instead:

% adb push 00Asetupwizard /sdcard/
% adb shell
$ su
# mount -o remount,rw /system
# mv /sdcard/00Asetupwizard /system/etc/init.d/
# chmod 0755 /system/etc/init.d/00Asetupwizard

(In the above examples, % indicates the shell prompt on your computer, to distinguish it from the ADB shell prompt.)

  • I haven't tried this, but I believe the adb approach should work. "Launchable activity" only means that there is no icon on the launcher, but any activities can be started using its fully qualified class name. The problem is, it seems this only works for Nexus device, and not all devices use the same .apk and that activity. – Andrew T. Mar 16 '15 at 4:33
  • I tried this with the CyanogenMod 12 setup wizard which likewise doesn't have a launchable activity, and it didn't work. I've heard that people have reported the same with the Google setup wizard. – nyuszika7h Mar 16 '15 at 17:56
  • Just tried on Nexus 5, stock Lollipop 5.1.1, and yeah... it didn't work :( – Andrew T. Jun 24 '15 at 8:32
  • On first boot, running am force-stop com.google.android.setupwizard and then restarting it by running your am start command works. It appears that it removes itself after completion, because it fails afterward and pm says it doesn't exist. – Matthew Read Jul 20 '15 at 16:57
1

You can find it in your app drawer. Some vendor named is Setup, some may named Wizard. You might want to sort your installed apps in app drawer and start looking from oldest ones.

  • I have it in my HTC One X. I had it in my old Desire S and Desire HD. – Min Naing Oo Apr 9 '14 at 13:30
  • 1
    @RossC - I have a Galaxy S3, and the application is present named "Setup Wizard". Perhaps you have disabled it? See Settings > Application manager > All, and search alphabetically. If it is disabled it should be at the bottom of the list where disabled applications reside. – wbogacz Apr 9 '14 at 13:31
  • EDIT: It is in my applications list in settings as suggested above!! It is not deactivated/disabled but it is not in the app drawer and I cannot open it! Apologies for the confusion! So now that I know it's here, how is it opened? Edit 2: Actually it's there on the S4 too and a coule of others. It is present, obviously it runs on startup, but can it be re-reun / invoked without resetting? – RossC Apr 9 '14 at 13:32
  • I just look into Xperia TX and the app is not in app drawer. But it is in Setting->App and named as Setup Guide (not disabled) so that must be hidden by system. I just tried to launch it from LuckyPatcher but didn't success (unable to launch error). May be because I've force stopped it? – Min Naing Oo Apr 9 '14 at 13:51
  • Hello, I've edited my question to make it clearer. I want to have the welcome screen run at startup, so I guess I have to edit some configuration file to achieve this. Anyway, I've never found the "Setup" application in the app drawer of any Android phone/tablet I ever owned. – OMA Apr 9 '14 at 17:27
0

for those you got newer GMS, it seems the name of activity changed, try

 adb shell am start -n cotupwizard/.SetupWizardTestActivity 
instead.

protected by Community Oct 16 '15 at 15:33

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.