0

I had rooted my device and hidden the SuperSU app using an app called Apphider which requires root access to function. I applied the Android 4.4.3 OTA update successfully. Now I cannot unhide SuperSU or update it in any way. Upon checking for root using root checker apps, it still showed that the device was rooted. In an attempt to fix the issue, I had removed the root files also(/system/xbin). Now I am unable to install the binaries also. So is there any way I can grant superuser access to the hider app exclusively and then reinstall SuperSU and the binaries?

0

You can flash SuperSU from recovery (CWM or TWRP) to reinstall the su binaries again. You should then either have SuperSU already installed, or you can install another SU app. Then install Apphider again, grant it root, and then unhide SuperSU if it's not already showing. I ran into something similar yesterday while applying the OTA to a rooted Nexus 5, and this fixed it.

  • Thanks. I reflashed twrp and installed SuperSU from it manually. That solved the problem – Vedaj J Padman Jun 9 '14 at 20:42
  • Glad it helped! – filoxo Jun 11 '14 at 13:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.