0

I am using a Sony Xperia L (C2104) with Android 4.2.2 (Build number 15.3.A.1.17).

I can only find one setting that would turn on Wi-Fi automatically, and it is the "Location-based Wi-Fi" setting in the Power Management settings category. Of course, I have disabled this option, but I frequently find my Wi-Fi on. How can I fix this?

0

This problem might be caused by some third party application installed on the device. I faced this problem with quite a few applications like "Fast File Transfer", "Super Beam", etc. Applications that require to use the wifi-direct feature seem to create the problem. I uninstalled both the applications and the device wifi was normal again after a reboot.

4
  • Hm I seem to have no applications that require Wi-Fi direct feature; the closest thing I have is the bloatware File Commander, which I use and has Wi-Fi direct capabilities (although I never use the latter). Do you think it may be a culprit? Is there some way I can debug this? – Severo Raz Jul 11 '14 at 5:40
  • My devices problem was solved by uninstalling the applications and since then, any other application hasnt caused this. Did you try SafeMode? I have been using ES File Explorer for Wifi direct transfers but it hasn't ever created this problem. Might be your Firmware is corrupt, try reinstalling or Upgrading. I searched Xperia Forums and found out its a common problem faced by many users. Need not to worry, sony will fix it (Hopefully!) – srivmanu Jul 11 '14 at 6:25
  • How do I enter safe mode? I would remove it but I don't know if I would be able to fetch it back afterwards :/ I hope Sony realized that this issue exists. – Severo Raz Jul 12 '14 at 18:09
  • People have added it into the forum for Bugs/Errors on Sony's site, so we assume Sony knows. Now, to enter Safe mode, go to the power menu, i.e. the one which you get after keeping the power button pressed. Then keep the "Power off" button pressed on the dialog box that appears, it should ask you to reboot into safe mode. The File manager, and even better ones are available on the play store, don't worry about that. – srivmanu Jul 14 '14 at 4:12
0

you can try this ...

  1. settings > apps > all > smartconnect > clear everything

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.