0

I can't seem to find a way to root my android device. I have tried every rooting method that I can find on the Internet for the SC-O6D, everyone of them after flashing are supposed to reboot the phone back into Android with root. But everyone I flash the phone reboots and no root? Anyone think they know what is going on?

  • 1
    What exact steps do you take? Please edit your question to add this information. – Dan Hulme Sep 11 '14 at 6:07
0

There is a binary in /system/bin which continuously checks for root and immediately remves it again, as soon as root is detected. Chainfire root tools used to have an automated removal tool affecting this security binary. You can also do it by hand.

I do not know it by hard, the name of the binary. But you could extract the auto-root in the link below and you will know it. Or you can simply use it.

http://download.chainfire.eu/248/CF-Root/CF-Auto-Root/CF-Auto-Root-d2dcm-sc06d.zip

Have fun!

  • I attempted to flash the file and the phone just rebooted without root. I'll probably attempt to manually find the file shortly – Crashbash111 Sep 11 '14 at 20:49
  • Strange. For me it worked, but that was a while ago. Perhaps they changed it with an update. You could try to flash it again? – user3387542 Sep 12 '14 at 5:14
  • I tried like 5 times and no luck. I also fried kingsoroot which after 10 minutes said it successfully rooted, but when it started back up there wasn't any. It's running Android 4.1.2 – Crashbash111 Sep 12 '14 at 9:14

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.