1

I've bought a Lenovo A7 3300 16GB tablet running Android 4.2.2. I tried to updated my tablet to the last version of Android by going into Settings > About phone > System update, but when I tap on "System update" this message appears on the screen:

Unfortunately, settings has stopped.

In addition, my GPS is not working properly. I can turn it on, but it doesn't locate my position on Google Maps or other GPS apps.

My tablet is not rooted and I don't want to root it. I've tried factory reset many times, just for the record.

  1. Is there any way to fix these problems without rooting?
  2. What causes these problems?
  3. Is this a hardware problem or a software problem?
  4. Should I bring my tablet back to the seller?
2

There a couple of things you can try out, in any order you like!

  1. New Tablet? Surprising, try a factory reset if you have nothing on it. This should fix it for most cases.
  2. A single application crashing could be due to some stale values associated with the data it has cached, you could try force stopping the settings application and then clearing the storage.

If this doesn't work, check for the latest stable build of a rom for your device from the vendor itself, you might have to flash it.

Edit:

Just saw Jeff Chang's comment, and my answer is similar to the one on the link he provided. If it works, you can ask him to answer it for you and award him the bounty.

  • Unfortunately I had 7 days to return the device to the seller. So before your answer. I've sent it back. I don't have the device right now and I'm going to change it with another brand. Thanks for your time and effort. I vote your answer up. – Siamak A.Motlagh Oct 7 '14 at 17:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.