1

I recently upgraded my Android to 4.4.4 via 4.3.? When I was on 4.2.* I had no problem either uploading apks and pictures via usb nor via adb install / push.

Symptoms below, any help appreciated. I'd rather not have to root the phone but if I must I must...

Since I upgraded the USB upload has started to act strangely:

  • I can download any file
  • I can upload text files
  • I cannot upload apks
  • I cannot upload apks renamed to .txt
  • I cannot upload xml, jpg or anything other than plain text
  • It is not a size issue I can upload large text files
  • I've tried both MSC and MTP modes.
  • I've tried different PC's and cables
  • If I try to upload a binary from windows 7 copy dialog that stays on screen forever doing nothing or sometimes the storage resets on the phone and it errors.

ADB has stopped working from within eclipse I get:

[2014-10-07 19:14:25 - BluetoothTest] ------------------------------

[2014-10-07 19:14:25 - BluetoothTest] Android Launch!

[2014-10-07 19:14:25 - BluetoothTest] adb is running normally.

[2014-10-07 19:14:25 - BluetoothTest] Performing uk.co.dossytronics.bluetoothtest.MainActivity activity launch

[2014-10-07 19:14:40 - BluetoothTest] Uploading BluetoothTest.apk onto device 'CB5A1PVTNA'

[2014-10-07 19:14:46 - BluetoothTest] Failed to install BluetoothTest.apk on device 'CB5A1PVTNA': An existing connection was forcibly closed by the remote host

[2014-10-07 19:14:46 - BluetoothTest] java.io.IOException: An existing connection was forcibly closed by the remote host

[2014-10-07 19:14:46 - BluetoothTest] Launch canceled!

From the command line: C:\android-dev\sdk\platform-tools>adb -s CB5A1PVTNA install c:\users\dominic\workspace\BluetoothTest\bin\BluetoothTest.apk

protocol failure

error: device not found

  • waiting for device -

rm failed for /data/local/tmp/BluetoothTest.apk, No such file or directory

0

After a lot of messing around I think I've nailed it. It was an application called "Sony Smart Connect". Like most things that contain the oxymoronic phrase "Sony Smart" is anything but smart. Instantly everything went back to working and I can now get on with coding until the next update stops me for a month...

I hope this is of help to someone in the future.

Dom

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.